6

Got the dreaded "There was a problem communicating with Google servers, try again later" error. This all started with notifications stating my account could not Sync with any of my apps. Seen many posts with possible solutions ...

  1. Removed the account, then tried to re-add it and got the above message. Tried to add other accounts ... same thing.
  2. Verified 2-factor auth is not enabled
  3. Cleared cache and data from all Google-type apps on the phone, uninstalled all updates for the apps ....restarted
  4. Verified the date/time setting and timezone setting are automatic and they look correct
  5. The network and wifi are fine ... can browse to the Google sites
  6. Non-rooted phone. Nevertheless verified the hosts file is legit
  7. Not willing to do a factory reset yet since other posts suggest this does not always fix the issue and that would only lead me to likely throw my phone. Unintended consequences.
  8. Tried unlocking Captcha on Google Account

This happens no matter which Google Account I try to add, making me think it is not account related rather something on the phone

I'm at my wits end now ... clearly there is a serious issue here and I can't put my finger on it. Does anyone have any suggestions.

Thx

  • I have this error and I just realized my /etc/hosts blocked play.google.com – 林果皞 Nov 21 '17 at 19:33
5

I have finally found the solution for this problem and want to share it here for those of you suffering from the same issue that was not answered by any of the steps mentioned in the original post.

In short, I needed to reinstall Google Play Services

In your device ...

  1. Go to Settings > Security > Check Unknown sources
  2. Head over to APKMirror and get the version of Google Play Services that is applicable to the your Android version.
  3. Install
  4. Probably best to reverse step 1 once finished

This worked for me.

protected by Community Jul 18 '15 at 5:48

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.