I have tried to root lenovo a7000 a with kingo root application with no success. My computer will be infected due to this method as the download page for apk file forces me to download malicious file.SRS Root claims to support this device but is SRS Root safe? Is there any other way to root my device ?

  • Please check android.stackexchange.com/questions/1184/… – rjt.rockx Apr 24 '15 at 16:27
  • @rjt.rockx The link that you mentioned has the name A7000 in the rooting guide index, but its reference is to this question itself. It was last edited few minutes ago before your comment. The gist is that the link isn't helpful to OP here. – Firelord Apr 24 '15 at 16:57
  • This article posted one day ago seems to have worked for some people. The instructions are rather vague though. Proceed at your own peril. – Vinayak Apr 25 '15 at 14:40
  • Looks like this tutorial explains the process better. Try it out and see if it helps. – Vinayak Apr 27 '15 at 19:19
  • @Vinayak I followed the tutorial. Everything worked fine until the second last step. The download never started(My device is fine) – Arun Apr 27 '15 at 21:16

maxritz from XDA Developers has built a ClockWorkMod (CWM) recovery that works for Lenovo A7000-a by porting the CWM recovery for Lenovo K3 Note.

Here's a link to the recovery file: A7000-CWM-Final.zip

You'll need a Windows computer and Smart Phone Flash Tool to flash the recovery file. Instructions on how to flash CWM using SP Flash Tool are listed here and here.

Once you've flashed the CWM recovery, you'll need to get the latest version of SuperSU and flash it by booting into CWM recovery (do that by turning the phone off, depressing the volume keys and then pressing the power button until you boot into CWM) and selecting the ZIP update package.

You can get the latest version of SuperSU in ZIP format here: http://download.chainfire.eu/supersu

According to maxritz, you'll need to delete the recovery-from-boot.p file from the root filesystem /system as it may overwrite the recovery and undo your changes. You could do that by using a file manager app like AROMA Filemanager that works in Android recovery environment. Usage instructions and download links for AROMA are available here.

NOTE: Rooting your phone will most likely result in loss of warranty.

  • Doesnt work for me...gives me a BROM Error 5054 saying the ROM doesnt match...any help..?? – Fr_nkenstien Mar 11 '16 at 22:11
  • @VineetVerma try following the instructions from this XDA post – Vinayak Mar 11 '16 at 23:43
  • @Vinayak...this is not working for me somehow...with volume+ it fails at 5054 BROM Error, but with volume - nothing happens at all...:(...please suggest – Fr_nkenstien Mar 12 '16 at 13:25
  • @VineetVerma I googled that error and it seems to be associated with flashing incompatible firmware. I can't be of much help here but you should ask for help on the relevant XDA thread. If you're open to alternative solutions, I've had some success rooting phones using KingRoot. Let me know if it works out for you. – Vinayak Mar 12 '16 at 15:21
  • @VineetVerma You can also try your luck by flashing firmware available on 4PDA. The instructions are in Russian though. – Vinayak Mar 12 '16 at 15:39

Try using the Framaroot app. Just Google it, copy it to sd card, enable installation from Unknown sources , and follow the steps it suggests.

  • I have installed Framaroot. Whenever I open the app it says" Your device seems not vulnerable to exploit included in Framaroot." – Arun Apr 24 '15 at 16:35
  • Then, try using MTK Droid tools. – rjt.rockx Apr 24 '15 at 16:57
  • @Arun, as suggested here, MTK Droid Tools should help out since it has a root option and is mostly not flagged by antivirus. If it doesn't work, download latest SP Flash Tool (support for mt6752 added), a custom recovery and flash your recovery using that tool. Once you've a custom recovery installed, rooting seems piece of cake. androidxda.com/smart-phone-flash-tool – Firelord Apr 24 '15 at 17:12
  • @Firelord I downloaded MTK Droid tools v.2.5.3 from here. I scanned it with antivirus and it contained a threat "Linux.CornelGEN.755". Is it a virus or adware ? The antivirus(Bitdefender 2015) deleted the exe program when I tried to resolve it. Can you (or anyone) please refer a secure source for downloading it? Thank you. – Arun Apr 24 '15 at 17:34
  • It is secure. I have personally used it to root and install a custom recovery to my device. It uses such things to root your device and access it's kernel. – rjt.rockx Apr 24 '15 at 17:35

First, I’d like to recommend Framaroot. But it didn’t work for you. So try iRoot for PC version. iRoot has two versions for Android rooting, which are both safe and fast. Basically, the PC version has the higher success rate. But if your Lenovo A7000 is with Android 5.1 and up, it may be still useless.

  • Can you please find us some posts where users have used this tool successfully on their Lenovo A7000? Every one-click root app depends upon a vulnerability and linking those posts would increase the assurance that the tool is worth trying (as well as taking a risk). – Firelord Mar 4 '16 at 18:43
  • I tried iRoot App..its a spam app...spams ur system with virus and ad apps....never go with that – Fr_nkenstien Mar 12 '16 at 13:29

Not the answer you're looking for? Browse other questions tagged or ask your own question.