I have downloaded more than once yureka upgrade to cyanogen 12 based Lollipop 5.1 but my OS is not being updated. I have tried rebooting the phone after download but to no effect. I am still using old version. Unable to download new version. Please suggest how to resolve this issue?

  • Hard to say without some more details: What Android version (and ROM) have you currently running? What steps did you do to download? Where there any instructions you've been following?
    – Izzy
    Apr 27, 2015 at 13:17

1 Answer 1


below are not be done before you upgrade: Rooting, developer mode on, phone memory full - if this is exist then you cant update and the downloaded file must be kept in phone/download not on sd.

If your downloading from OTA then this are not to do list: and to make you simple download from google and place it on the download place in phone memory then you give it a try if this helped you fine else tell me were have you done mistakes so that clearly I can suggest you. as of mine updated and running smooth.

  • Can you make it bit more presentable by using android.stackexchange.com/editing-help Its good that you're helping and the method worked for you, but if the answer cannot be understood easily, the answer might not be considered useful.
    – Firelord
    Apr 28, 2015 at 6:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .