0

My Nexus 4 device stopped connecting to the Cisco router at work for some reason. I thought it was because the upgrade to lollipop 5.0 (had Kit-Kat before) but I'm not so sure anymore.

I tried:

  • Restart the device
  • Restart the device with safe mode
  • Restart the router
  • Change the device WiFi frequency settings
  • Use static IP at the advance WiFi connection configuration
  • Forget the router AP and reconnect
  • Factory reset trough the device settings, recovery mode and complete flashing the Android Lollipop 5.1 factory image.

After factory reset I had the connection possible until restarting the device. I checked with/without signing in, nothing new installed, didn't visit the store, just super clean phone - I could connect the network. after restarting the phone I can no longer connect which means it's not an application issue.

Some facts:

  • I can connect other Cisco routers at work
  • Another Nexus 4 after factory reset connects with no trouble

About the device:

  • Nexus 4
  • Lollipop 5.1
  • build number LMY470
  • kernel version 3.4.0-perf-gf75bb4f

Any suggestion will be welcome, please let me know if I can provide more details.

  • 1
    It sounds like one of your apps is causing the problem. You may have to reload them one-by-one until you find the culprit. – Joe Sewell Apr 27 '15 at 20:37
  • sounds so. do you know an easy way to do it? should I restart after each app uninstallation? – Tamir Apr 27 '15 at 20:38
  • That might be easier than a factory reset followed by installing one at a time until it stops working. The problem, though, is that the culprit app might have modified a setting that won't get cleared without a factory reset. – Joe Sewell Apr 27 '15 at 20:40
  • @JoeSewell It doesn't seems like app issue. I updated the question. – Tamir Apr 28 '15 at 7:19
0

Some sites recommend to restart the router device, and sometime it works. Instead of every time restart the router to solve this Android 5.1 Wi-Fi problem, it worked for me:

Inside the router configuration (e.g., accessing the IP 192.168.0.1), change the "Group key update" value from 0 to 30 seconds, under the "Wireless > Security" configuration, right below the WPA-PSK/WPA2-PSK item.

My router model is: TP-LINK TL-WR740N / TL-WR740ND.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.