1

I wish to ssh into my rooted Android Samsung Galaxy S4 v4.4.2 phone and run a command. I have SSH Server installed. If I just SSH, it works fine:

bash-3.2$ ssh -p 35151 10.1.10.22 
u0_a253@jfotevzx:/ $ pwd
/

But, if I pass a command to execute to ssh it fails:

bash-3.2$ ssh -p 35151 10.1.10.22 pwd
exec request failed on channel 0

What does exec request failed on channel 0 mean? How can I get the SSH Server from Ice Cold Apps to work with a command to execute? Is there a different ssh android app that I could use instead that would work?

0
1

I found a forum post that indicates that the Ice Cold ssh has a deficiency that causes this issue. By switching to SSH Droid, I was able to resolve the issue.

1
  • I tried this app just now and was able to reproduce this error. On the other hand, Servers Ultimate Pro doesn't have any said issues. It worked well with the command you mentioned in the question. – Firelord Apr 27 '15 at 17:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.