1

I'm on an unrooted Verizon Galaxy Note 4 running Android 4.4.4.

I have not accepted the Lollipop preparation updates, because Android 5.0 on Snapdragon processors is known to have poor performance when using Gear VR.

In the last week I've noticed that USB debugging is grayed-out, even when plugged into a Windows 7 computer. I have tried using different USB cables and different computers.

I need to be able to use EasyTether, which requires USB debugging.

I have tried rebooting to Safe Mode, but this didn't help. USB debugging is still disabled.

  1. Is it because I have deferred the OTA updates? How can I restore USB debugging without accepting the OTA update?
  2. I've been using Samsung KNOX for months now and it hasn't interfered with USB debugging. Has something changed with Samsung KNOX?
  • It's probably because of the fact that you are running a Verizon phone. Carriers like Verizon tend to replace parts of the firmware (Bootloader, Android itself etc.) with their custom one to restrict things like Network Unlocking. – GiantTree Apr 27 '15 at 20:30
  • I have used USB debugging as recently as three weeks ago on this exact same phone running the same version of Android. – Elle Fie Apr 29 '15 at 2:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.