So I moved out, carrying along my WiFi router. I set it up at my new place, but now, every time I use a location service, it recognizes my router and places me at my old address... Any way I can force the new location to be recognized for my router?

Thanks!

  • Seems like your IP's location has not changed. If you have a static IP (commonly used in the US, less in Europe) then you need to wait for the record to change. Make sure you have informed your ISP that you moved. – GiantTree Apr 27 '15 at 20:31
  • 2
    @gianttree - this is a location services issue not a IP problem. Google has stored his network's location as the previous location – sloosecannon Apr 28 '15 at 14:07
  • AFAIK your location is stored at your ISP's network switch (at least where I live). Google may or may not save that location based on various different properties (MAC, IP, SSID etc). – GiantTree Apr 28 '15 at 14:26

I have the same problem with a WLAN router I have bought recently. When I connect my mobile without GPS on it usually places me at the location of the former owner. I assume the router location is bound to the router's unique MAC address - not to it's IP or the SSID which both have changed now.

ZdNet's article says, the location database will become updated when connecting a mobile with it's GPS "on" to this router. More info about Google's location service can be found here.

To submit a request to Google to have them update their database, send feedback from within the Google Maps application.

  1. Open Google Maps.
  2. Touch the menu (three lines).
  3. Touch 'Send feedback'.
  4. Touch 'Report location issues'.

This what Google requests you do.

To address the problem without contacting Google: The location databases use the MAC address of the router. On most routers, you can change the MAC address, which will prevent your old address from showing up. If there are other access points in your area, this may also be sufficient for the location service to return the correct location.

Another possible solution is to change the SSID on the router. That should force location services to retry its location

Same Problem here.

FIXED. Took about 5 mins to update and correct location.

  1. Connect your mobile to the Wifi router with GPS on. Run Google maps and ensure the blue dot moves to correct location (Get sat signals near window). Mine gradually glided from old address to new.

  2. Connect a tablet (Eg. I used Samsung S2), connect to Wifi and turn on GPS. Run google maps and again ensure blue dot moves to correct location (get sat signal near window)

  3. [Prob optional] - Get you home location on google maps by dropping a pin at your new address and calling it Home. I also changed Icon to a house

Once blue dot had relocated on a couple of devices with GPS, then my laptop / desktop also updated the blue dot location. (on closing and reopening G maps)

hope it works for you too.

Wile E Coyote

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.