Huawei Ascend G300 - Android 4.0.3:

The phone has a problem with the "gapps" says the applications all the time that the Google play, Whatsapp, twitter, facebook stops working stop.

try to make a factory reset to see if this error and solved but nothing still continues to errors

try other options;

1) Hard reset did not work out. 2) Update firmware did not work out. 3) Downgrade did not work out.

apparently I can not retrieve the phone do not know how to restart the factory.

Here's what I did:


original text in spanish:

El teléfono presenta un problema con el "gapps" dice que las aplicaciones se detienen a cada rato que el Google play, Whatsapp, twitter, facebook deja de funcionar.

trate de hacer un factory reset para ver si con esto solucionaba el error y pero nada aun sigue dando errores

intente con otras opciones;

1) Hard reset no funciono. 2) Update firmware no funciono. 3) Downgrade no funciono.

al parecer no puedo recuperar el telefono no se como hacer para reiniciarlo de fabrica.

  • What do you mean by "formatting but do not take changes"? Formatting does change the file system. In the context of your question: are you talking about a factory-reset – or about formatting file systems? In the latter case: which ones are you formatting, and how? What kind of update are you trying to apply? There seems to be a language barrier here – but it's hard to understand what you are asking.
    – Izzy
    Apr 29, 2015 at 14:22
  • If I just tried to restore factory and can not be, either with the "Hard reset" nothing works ... I reboot and the phone continues as it seems like this is a problem gapps I can not even change the recovery.img
    – ccdiego5
    Apr 29, 2015 at 17:30
  • Not blaming you for the language barrier, Diego! To find some clues, the system logs might be helpful (see: How can I view and examine the Android log?). Apart from that: Is your device running an "official ROM" provided by Huawei – or did you do any modifications to it (root it, install a custom ROM)?
    – Izzy
    Apr 29, 2015 at 17:52
  • If course has an official rom "Ascend G300 Software (U8815-1, Android 4.0.3, V100R001C407B958, Venezuela-Channel, 05011LGK)"
    – ccdiego5
    Apr 29, 2015 at 17:55
  • 1
    I can see why the last command might fail (bootloader locked) – but fastboot -w (wipe/factory-reset) and fastboot erase cache should even work on locked & unrooted devices. Guess I have to leave that to someone familiar with that specific device (hint: please edit your question and include: device name, Android version). If you still can boot the device and reach into settings, you can try a factory-reset from there.
    – Izzy
    Apr 29, 2015 at 18:38

1 Answer 1


Have You rooted Your phone?

Seems like accidently you have removed any one app which is required for gapps.

The solution is to download gapps package for you android version and flash via recovery.

  • ¡Houston we have a problem! I'm just getting started with android try to do many things: -Unlock the S-OFF and could not. -try to install an update by dload and fails when in step 2. -Try to depress operating system version. and not to do anything really. just try to search in forums someone can explain to me how to do this because I try several times to change the "recovery.img" with "G300-superrecovery" and simply fails because and I could unlock the bootloader fails tells me I can not access is denied; and whatever you do restart the phone again be as it as it was before shutdown.
    – ccdiego5
    Apr 29, 2015 at 13:34
  • prntscr.com/6zix6b
    – ccdiego5
    Apr 29, 2015 at 13:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .