4

Little bit of background, at my place of employment wifi is provided (a free version which isn't locked, and a version which is locked). I don't want to connect to either. It keeps connecting to the unlocked wifi network. I went into Settings->Connections->Advanced and turned off almost everything I could think of, but it still scans for networks and connects to the open free network. I want to control which networks I connect to and when. Whether they are free or not (especially if they are free as I imagine that's how hackers get access to your personal info). How do I get my phone to STOP doing that. Only connect to a wifi network when prompted by me!!!

  • 1
    Did you "forget" the bad network. Afaik you will be asked by the phone at least once before connecting – wlraider70 Nov 28 '15 at 2:38
0

I don't wish to insult your intelligence, however would disabling your WiFi from the Notification Menu not simply stop your device from connecting to the WiFi network?

  • I have no pride. My intelligence can not be insulted as I am not sure I have any to begin with. I have tried disabling from the Notification menu, but just in case my intelligence is too big for its britches, could you sketch out the steps (StepA -> StepB -> StepC ->ETC...) – SoftwareSavant Apr 29 '15 at 19:23
  • Sure. 1. Drag down from the top of your device screen, the notification menu and a range of quick action buttons will appear. 2. Assuming your phone is connecting to the WiFi, the 'WiFi' quick button will be a green colour signifying it is enabled. Touch the button once, and wait for it to turn light grey. This means your WiFi is off. 3. Pull up the notification menu, and look at the status bar. There should be no WiFi symbol visible and your phone isn't connected to a WiFi network. – IncognitoJam Apr 29 '15 at 19:25
  • So that is my problem. I go through those steps. But eventually my phone tries to reconnect to WIFI!!!! I don't want it to even look until I tell it too. – SoftwareSavant Apr 29 '15 at 19:59
  • 1
    Under WiFi Advanced, do you have a setting 'Scanning always available'? – Paul Ratazzi Apr 30 '15 at 15:39
  • 1
    On my Galaxy Note 2, I have a "Connections Optimizer" setting which looks for wi-fi connections you have previously used. This may be the culprit. – Laconic Droid Apr 30 '15 at 22:44
0

In the list of wifi networks, you can select the open network, then "forget this network" -- after doing that, the phone won't connect without asking. As long as you don't give permission, and have "automatically connect to open networks" disabled, the worst it will do is prompt you to connect to this "new network".

protected by Community Jan 28 '16 at 18:59

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.