Please tell me there's a solution to this..!

SHORT version:

Normal startup: Stuck at Google screen.

Unlock bootloader: Stuck at selection.

Recovery mode: Stuck at Google screen.

Long version

My Nexus 7 2013 had always been fine, and I liked stock android very much, thus saw no need to unlock the bootloader. When the 5.1 OTA came, I updated my N7 and it started crashing and restarting on its own. One day, it restarted again and got stuck at the Google screen.

Of course the first thing I did was to get the Nexus Root Toolkit, and tried flashing stock rom. Of course it didn't work since it was oem locked. When I tried to unlock the bootloader, I was prompted with the screen asking if I want to unlock and wipe all data. I selected unlock and pressed the power button. Then it froze (I left it for 8 hours, plugged in to a power outlet).

The next logical thing to do was to start recovery mode in the fastboot to do a factory reset, except it simply switched to the Google screen and was stuck there.

I'm pretty desperate now, that's why I'm posting here. Sorry if it's the wrong category or something. I've read many articles, but it's always ONE of the THREE issues I have. They often refer to using a method that involves an area where it's affected by the other problems.

Please help me, I don't want to see $250 down the drain :(


This sounds like a common bug that has been reported on recently by Android Police. To summarize:

Affected units stop booting at the "Google" logo screen. Attempts to unlock the device through fastboot fail at the "erasing userdata..." step, leaving the devices locked. Some users report successfully flashing factory images on unlocked devices, but this still doesn't fix the problem. There are mixed reports about starting up in Recovery, with some users complaining that the Nexus 7 freezes, and others being able to get in to perform some maintenance.

There are no know solutions at this time. Sorry to bring bad news. I hope I'm not right.

| improve this answer | |
  • Thank you, at least now I know I'm not the only one with this problem, and that some of the solutions I've been trying aren't going to work afterall. – Panpaper May 3 '15 at 21:39
  • Yeah, it sucks. You might try contacting Nexus support, just to see if they'll do anything. Not sure they will depending on when you got the N7. – Thomas Martin May 4 '15 at 12:30

Just happened to me too yesterday. First, touch screen became unresponsive. After restart, stuck on google logo.

Search google, found this thread. Someone here suggested to knock the backside of nexus 7.

I did that and...Boom!!! Google boot animation appeared. My nexus 7 2013 is ok for now


| improve this answer | |
  • I've read on several websites that say knocking on the sides or the back seemed to solve the problem for some users. It raised a bit of hope in me, but I've not had any luck so far. Could you maybe specify the following: 1. Where on the tablet did you knock it? 2. When during the startup did you knock it? 3. How long did you have to wait? Every bit of information helps, thank you! – Panpaper May 22 '15 at 2:24
  • Tapping on the back of my Asus Nexus tablet fixed allowed me to leave the logo screen and boot properly as well. I would like to understand why that worked! – joshgoldeneagle Oct 1 '16 at 5:30

Indeed tapping (5 times for me) on the back side of nexus tablet (on the logo) while the screen is stuck on Google Logo, lets the tablet start successfully.

| improve this answer | |
  • 1
    So, you believe something is loose inside your device, and the vibrations during the tapping makes the connection solid enough to proceed? – wbogacz Dec 11 '15 at 13:26
  • This was such a long time ago, I got a new tablet now and saved myself a lot of frustration. Nonetheless, I tried your method but it didn't work, thanks anyway! – Panpaper Dec 11 '15 at 22:00
  • Tapping on back worked for me. I would like to understand why. – joshgoldeneagle Oct 1 '16 at 5:32

I had the same problem with the Google screen being stuck at start up. I tried several things to fix this, and as a JOKE to my husband, tapped the back of the nexus 7 logo 4 times with the palm of my hand. I swear, after about 10 seconds, the boot animation appeared, and my nexus 7 is now working.

| improve this answer | |

I had the same problem as well, and was stuck at the Google logo whatever I tried.

I was able to unlock the bootloader and install custom recovery (TWRP), and a custom ROM using the "Nexus Root Toolkit" and fastboot. But I was still stuck at the Google logo. But then I found this post and gave the tablet a few knocks on the back and sides, and suddenly it started booting into the custom ROM I installed!

EDIT: My touch was also unresponsive. But now even that works :)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.