4

I've installed Android Wear on my Lollipop device and when it launches it says it needs a new version of Google Play Services. But when I click on the Update Google Play Services button nothing happens. I tried searching for Google Play Services on the play store but it doesn't appear in the search results (but it does appear in the results if I search on a laptop browser, but it doesn't if searching directly on the phone). How can I update the damn thing to get Android Wear to work??

  • 1
    It should just do it behind the scenes. Is it repeatedly prompting you? – Matthew Read Apr 30 '15 at 19:14
3

I ran into the same issue recently when using transit app. This is how i updated Google Play Service. On your Android Wear go to settings -> About -> Versions -> Google Play services. When you press on Google Play service it will check for update and install it.

  • Procedure is correct but when it deems to work and not work seems spotty at best. – Linef4ult Feb 10 at 18:05
0

Here's the Play Store entry for Google Play Services in case you're looking for it.

0

Go to Play Store > Settings on your lollipop device. Click Build Version. Do you see a dialog telling you if Play Store is up to date? Does it now update itself if necessary?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.