I have a Micromax AQ4501 mobile phone. I am getting an exclamation mark over the Wi-Fi icon. And I am unable to connect to Wi-Fi thereafter.

I have been facing this problem since a few days after I upgraded my phone to Lollipop 5.0. I tried many things like:

  • switching off and then on,
  • replacing SIM from slot 1 to slot 2,
  • switching mobile data and Wi-Fi connection on and then off

but all in vain.

I called the Google call center but they were also unable to help me.

I am able to use internet through mobile internet, but unable to use Wi-Fi with this phone. My Wi-Fi is working fine on other gadgets like my laptop.

How can I resolve this problem?

marked as duplicate by Matthew Read May 2 '15 at 15:47

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • When you upgraded, was it OTA stock or custom ROM? Have you contacted Micromax (or phone support)? If custom ROM, have you contacted the ROM developer? – HasH_BrowN May 1 '15 at 15:13
  • Usually when there is an exclamation mark !, it is signifying that WiFi isn't fully connected. Meaning try open your browser, see if you have to login or sign in in order to finish connecting. – HasH_BrowN May 1 '15 at 15:20

in lollipop , '!' is shown usually when wifi is connected but unable to access internet for reasons like Sign-in into ISP webpage,etc .

i suggest u to turn off wifi router power supply and turn it on after 10 seconds, this solved same problem for me

  • It shows this ! even when I can access internet easily on my lollipop. – Firelord May 1 '15 at 13:28
  • tried to connect different network ? – pola sai ram May 1 '15 at 13:30
  • Same issue on others too. ROM is fine. Wifi works fine. It is this mark that looks odd, very odd. – Firelord May 1 '15 at 13:32
  • does the mark appears at the time of connection or later after connected? – pola sai ram May 1 '15 at 13:34
  • It does so at both times. Also, the mark is there on mobile data too which is working fine as well. – Firelord May 1 '15 at 13:37

When I'm faced with this problem, I usually just edit the Wi-Fi network settings, by pressing the network name, and choosing "edit" (or "configure"). I then switch to" Static IP" instead of DHCP, and then manually input all the WiFi settings. This fixes the problem for me.

  • Did so long time ago, still the same issue. I left secondary DNS entry though, but it already defaults to 8.8.4.4. – Firelord May 1 '15 at 14:13

Try to forget all previous networks and then connect again to the current one. Hope this works.

  • What's the logic behind this? Not to mention, the issue persist in my device. – Firelord May 1 '15 at 18:46
  • Yes, could you edit your question and explain a bit more. – Maxime May 19 '15 at 6:53

Not the answer you're looking for? Browse other questions tagged or ask your own question.