1

SSO - Single Sign-on

ADFS - Active Directory Federation Services


My school requires Active Directory authentication, where after logging in through Google you are redirected to an Active Directory login prompt. In KitKat this redirect happened naturally when I went to add a Google account.

On Lollipop, for some reason Google decided to redo the process where it doesn't give me the chance to sign in to AD and just redirects to the page you get when you mistype your AD credentials.

I have tried logging in to AD in Firefox and Chrome incognito prior to adding the account and nothing. I even tried disabling Chrome in settings to see if it would default to Firefox but it seems the Google account setup process has a built-in browser.

Is there some file I can modify or copy to manually add the account, or is there a way to inject authentication into the Google account setup process?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.