Here's a sample scenario: when I'm at home and it's after 10pm, all call need to be silent, but family calls are enabled to ring loud.

Is it possible to do this? (preferably using Tasker, but 3rd-party apps is okay)

  • There is this example: tasker.wikidot.com/sleepmode and even have it on my phone but while I was testing it before putting it as an answer I discovered it doesn't actually work correctly. Give it a go while I tinker with it... – Dmitry Selitskiy Jun 22 '11 at 13:10
  • Yes, that is the behavior I am experiencing. I have been trying to modify the suggested profiles but with no luck so far. I'll do some more tinkering later today and report here. – Dmitry Selitskiy Jun 23 '11 at 9:20
  • I try to follow this example.Only work 1 group (favorit) -first rule:after 10pm it's set the phone to silent mode(working, icon appears top). -second rule:when a call comming from favorit group turn off silent mode (working, icon dissapiers),but the this call is silent :( (I think becouse,1rst is the call turn off the silent mode...) What now is (not?) working: the phone is in normal state 1rst rule: when an incomming call, who is not in favorite group,switch phone to silent mode. It's working but I can hear start ring and vibrate the phone about 1sec,before it switches to silent mode... – HyGy Jun 23 '11 at 9:22
  • I found this plugin to tasker: Locale Call Filter Plugin It's about what I wan't (but not 100%)... :( – HyGy Jun 23 '11 at 12:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.