0

House move, ISP screwed again, so I'm trying to tether from my Android 4.2.2 phone. This is UK, using t-mobile pay-as-you-go sim, with a 2GB data package. They appear to be tethering-friendly (EE own T-Mobile)

I can check email (secure POP, port 995), but not send (secure SMTP, port 465).

I can do searches on google, yahoo, duckduck, but in all three cases trying to follow a search result just sits there forever. All three of those sites does the annoying redirect thing, instead of linking directly to the target site, so the browser URL is still their site when it is not working - it does not get as far as the target site. The sites I tried directly also do not seem to work, e.g. I could not connect to stackoverflow. (I'm on free wifi at a coffee shop, currently.)

Outgoing ssh (on a non-standard port) worked fine.

An rdesktop connection failed (port 3389, I believe).

This has all been from Linux. I tried both Firefox and Chrome.

I'm a bit stumped where the problem might be: on my machine, at the android phone, or with the network.


UPDATE: As the fact I can write this shows, tethering is now working for StackOverflow (and related sites like this one), and also rdesktop is working. And clicking on google search results. (But not outgoing SMTP, that still fails.) Weird. Could it be bad DNS settings, er, or something, being cached??

UPDATE #2: Three days since I posted this question, and tethering continues to just work. I had just one period of no connectivity, but I was in a better troubleshooting position then, as I had two devices connected, both of which were affected. So I rebooted the Android phone, and it then worked when I tried again.

  • I guess. you connect to google by ssl - so your provider cannot read your http agent string... Can you use a socks proxy over your ssh? – davidbaumann May 3 '15 at 12:17
  • Thanks for the hint @davidbaumann. Is a socks proxy something I install on linux, or on the android handset, or is it a service I need to sign up for, and connect to first (like an http proxy I might use to pretend to be in a different country)? – Darren Cook May 3 '15 at 13:21
  • I think, this has already been explained once on the internet... – davidbaumann May 3 '15 at 14:02
  • Animal, vegetable or mineral? If you, or someone, can give me a hint, or a URL, I can do further research on what I need to install and/or signup for. – Darren Cook May 3 '15 at 14:30
  • 1
    2nd link is exactly what you want: wiki.vpslink.com/Instant_SOCKS_Proxy_over_SSH#Linux – davidbaumann May 3 '15 at 20:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.