2

I have Android 4.1.1 and my AnkiDroid version is 2.3.2. I have downloaded a deck (.apkg file) and I would like to import it into AnkiDroid, which requires me to place the file into a specified folder /storage/sdcard0/AnkiDroid.

Oddly enough, the AnkiDroid folder didn't yet exist, so I went on and created it, paying attention to the proper 'CamelCase' in the name of the folder. I have copied the .apkg to this folder but I cannot import it because AnkiDroid cannot find the .apkg in that folder.

What is the problem? How to fix it?

migrated from superuser.com May 4 '15 at 17:12

This question came from our site for computer enthusiasts and power users.

  • You shouldn't have had to make that folder, it's not possible for it to not exist if you can use AnkiDroid. What value do you see under settings>AnkiDroid>Collection path? There should be a file called collection.anki2 in the AnkiDroid folder. – Tim Rae May 6 '15 at 1:30
1

Strange, it should be seen in the Import dialog. Please fill a bug report at https://github.com/ankidroid/Anki-Android/issues thanks!

Meanwhile, you can use the second method for importing a .apk file:
https://ankidroid.org/docs/manual.html#_open_the_file_using_android
Just install any file explorer (like File Manager), and tap your .apkg file. It will open in AnkiDroid.

1

Hello i had the same problem before but now i know how to fix it. All you need to do is to locate 'ankidroid' folder in your file system, not in storage folder but outside of storage folder then just copy the .apkg files there. No need to make new folder or whatsoever.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.