5

Whenever I try to locate my new phone in the Android Device Manager, the following text is showed up:

Android Device Manager

Thing is, I am logged in as the primary Google account that my device uses. I also have the remote options in Google Settings > Security set to On, and the "Android Device Manager" checked in Settings > Security > Select Admins.

I don't really know what's going on, I've tried everything. Can someone help me? My phone is a Moto G2 XT1069, retail version.

  • Perhaps it's a different issue, but if you're using Lollipop, try deactivating the Guest account. – Andrew T. May 5 '15 at 0:54
  • I hadn't seen your answer, sorry. It was a different issue, but it was solved exactly the same way as the link you've posted. Thank you! – Anderson Linhares May 5 '15 at 15:39
1

Android Device Manager won't locate the device if it's currently not logged-in as the primary user. This applies to devices which support multi-user, including the default guest account on Android Lollipop.

Change the current user to your Google account on your device and try again.

In case it's still occurring on Android Lollipop, then try removing the guest account (refer to this question) and try again. It might be a bug related to guest mode.


Reference: Artem S. Lebedev's troubleshooting on Android Device Manager shows "No Active Devices" - Nexus 5 - Lollipop 5.1

Action: Switch to Guest Account in Lollipop interface.
State: ADM says that you must be a primary user.

0

I had this message while trying to locate my phone from the web interface. I do the message "You must be a primary user to find this device." with a link to Googles Timeline Maps feature.

Once I found my phone, and using the link provided by Anderson Linhares I was able to fix it by clearing data for the Google Play Store and Google Play Services.

I rebooted and opened the Play Store to sync back up. I got full functionality from the web interface afterwards. In my case, the rest of the instructions don't seem necessary.

0

In case you have more than one google account on the same phone you should remove it. for me and my Galaxy S8, the problem was having the Secure Folder enabled and inside it defined my Google Account too. I had to go to Secure Folder>Settings>Accounts and remove the Google Account.

-2

Even though it wasn't the same problem, I solved this by following these steps:

Phone not appearing in Android Device Manager

  • 1
    It's good that you solved your problem, but could you at least mention what specific steps did you take? The link provides some suggestions, but not all suggestions seem to work, so providing the exact steps will help the future readers too. – Andrew T. May 7 '15 at 1:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.