0

I installed a Nightly build of CM12.1 earlier today, but a few minutes ago when I tried to install an app that requires root access it said I wasn't rooted. For some reason I figured this was a given because I just flashed a custom ROM, but I am no Android developer (yet) and have no idea why it's not rooted. The ROMs that I installed prior to this didn't have this issue. Or it was spelled out in the install for me and I don't remember re-rooting them after I installed them. Either way, I need help with a method of rooting my Sprint Note 3 now and believe I need to use a specific tool or app to do so, and do not want to have to remove CM12.1 5.1.1 to do it (if at all possible). I also didn't want to run the wrong tool and screw up my phone because it was the wrong version of Odin (or whatever app I need to re-root). I'm pretty sure I have to use something specific to 5.1.1 but again, I'm no developer or heavy ROM flasher. If someone is a pro with Cyanogen ROMs I could really use some expert advice here. Thanks in advance!

  • Have you enabled root access for apps in the settings? – Izzy May 5 '15 at 10:33
  • Yes, and it didn't help. When I open the 'Root Checker' app and click on 'check root status' the blue Android alien pops up on my screen and the Android reboots. Not the whole smartphone though, just the GUI. – SeanPercy42 May 5 '15 at 10:36
  • Guess that's rather a bug in that nightly then. Never heard CM came without root – and I'm using CM for years. Especially that you have that option suggests it should be there. So I'd suggest either wait for an update, or use a previous nightly/stable instead. – Izzy May 5 '15 at 10:39
  • Wouldn't the earlier nightly builds of this same ROM have the same problem? Isn't there an app I can run like Odin where I can flash a file to my phone that will enable root but not damage my current data and apps? – SeanPercy42 May 5 '15 at 10:42
  • I cannot tell you whether an earlier or newer CM version has this issue or not – that's something to check with the CM forum. Not using a Samsung phone myself I neither can tell you about the Odin part, sorry. As I originally stated: it sounds like a bug in that CM nightly. So why not check where you downloaded the ROM, whether there are any reports or hints? Have you done that already? – Izzy May 5 '15 at 10:45
1

Enable developer options and in developer options menu you will find an option

enable root access

If not download supersu zip file and flash it via recovery and you will get back root access.Flashing latest supersu willnot affect the data.So no need to worry about data loss at all.

0

I just got a live CM12.1 update that (I thought) completely fixed this issue, but it's still happening. The root works when I first flash it but for some reason it stops after a while and, even with the root option enabled in the developer settings. I read on a different forum that the SuperUser app is no longer needed for the latest versions of their ROM, and thought that it was what was screwing up my root, but I didn't install it after last flash and it's still not working.

Update: I thought that I resolved the issue but it's still happening. Is anyone else using on a Sprint Note 3 using CM12.1 5.1.1 nightly and experiencing the same issue? It's getting really frustrating. Whenever I try to do certain things, like try to run Root Checker or Greenify, CM12.1 soft reboots. I know it has something to do with the root-access but can't for the life of me fix the issue.

0

My friend..I had the same issue and I fixed it right away.. Here's the trick: download the supersu zip file(I have the beta), go to the developer settings and switch on Advance Reboot..Then go back to the home screen.. Press the power bottom..it should give you a pop-up window where you can choose to reboot into recovery: Choose It..then in recovery mode.. Install the supersu zip you were downloaded and then install it..Reboot your phone and check root checker. It should work.

  • 1
    You shouldn't need to download supersu, since root is available in CM already. It's in Developer Options > Root Access. Just change it to apps only. – 1990clb Jul 2 '15 at 12:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.