0

My old phone connected to Android studio but new phone doesn't. I've spent a couple of days searching forums and sites to try to help but whatever I try, studio just isn't recognising the device.

I've enabled debugging in developer options, but the device isn't being seen. I can transfer files from the device as normal, but when I click run (to run the app), there is no device available in 'Choose a running device'. Any help would be very much appreciated.

Thank you,

2
  • 1
    I was writing answer to your question in Stack Overflow :).
    – Ali786
    May 6 '15 at 8:55
  • 1
    It might help if you'd name your device, Android version, and exact OS you're running on your computer. Also include whether you've installed the correct drivers for your device (when using some kind of Windows), or included the corresponding UDEV rules (Linux).
    – Izzy
    May 6 '15 at 10:36
2

It seems your computer is not recognizing your device or not able to download the device driver of your mobile phone Sony E2003

Possible solution is to download and install moborobo from this website in your computer

http://www.moborobo.com/

It will install the required device driver to connect your phone with the computer and then your device can be easily detectable in Android Studio

Hope this will help!!!

4
  • Hi Ali, Moborobo doesn't recognise the device, but sony pc companion recognises the device and is transferring files, I can also transfer just by connecting via USB and opening the device files. May 6 '15 at 10:10
  • Actually for transferring files you don't need to have device drivers, For connecting your phone in Debugging mode you need to have the device drivers are you able to sync your device with the PC using sony pc companion?
    – Ali786
    May 6 '15 at 10:26
  • Moborobo will download and install the driver have you scanned the QR code? what error it has shown while installing the device driver?
    – Ali786
    May 6 '15 at 10:27
  • Hi Ali, Thanks again for the response. Moborobo doesn't recognise there is a device connected at all. In connect device it tells me to connect device first, even though I'm already transferring files. May 6 '15 at 10:38
0

I managed to fix this myself, the developer settings were turning themselves off after I would enable. A reboot fixed the issue, for now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.