3

I have an Asus TM AC-1900 WiFi router at home. We have a Nexus 4, Nexus 5, Nexus 7, iPhone 6 Plus and notebook computers. They are all able to connect to Wifi when I get home. However, the new AT&T Samsung Galaxy S6 will randomly fail to connect to WiFi when I get home. It does manage to automatically connect some of the time but most of the time I have to remember to connect it manually. Is this a defect on my particular unit? I have tried doing a factory reset but it doesn't seem to help.

4
  • First off, when you go to wifi, tap on the "more" button on the top right, then tap on "smart network switch", and make sure it is turned off. Sometime it will detect that your wifi is unstable when connecting, so it won't connect. If that does not work, try tapping and holding on your network, then click forget, and reconnect to your network, but I have the S6 edge, and it auto connects to my wifi network all the time, so you might have gotten a defective one. Before you exchange it, I would test it out on another wifi network to see if it does that same thing. Let me know how this goes!
    – AJDev
    May 8, 2015 at 1:47
  • Also, are you sure you have the wifi on all the time? In wifi settings, tap on more, then advanced, then look for "Keep wifi on during sleep". I have mine set to always, so I don't have to keep turning wifi back on.
    – AJDev
    May 8, 2015 at 1:49
  • Thanks but after talking (after a log time being on hold and getting passed around) with AT&T, I exchanged the phone at a local store. Same problem again. AT&T placed a diagnostic app on the device but they didn't offer any more solutions. I've returned the phone and cancelled my plan. Still no idea why only the S6 should fail where literally nothing else does. How do I close a question?
    – Minot
    May 11, 2015 at 14:54
  • I’m voting to close this question because the OP cannot evaluate the answer anymore without having the device, and no existing answers have been upvoted for more than 5 years.
    – Andrew T.
    May 2 at 3:10

2 Answers 2

0

Was having issues with my s6 staying connected to open aps. Made sure the smart network switching was off, wiped cache and messed with other settings. Nothing worked. I opened up the AT&T smart WiFi app and adjusted the settings for public hotspots. No problems since making the change. I disabled the app no problems staying connected.

-1

Open the “Settings” and go to “Wireless/Wi-Fi”. Scroll down and at the end you’ll see the option “Smart network switch”. Uncheck this option and you’re done. For more details you can refer Samsung India site.

1
  • See How to reference material written by others. Posting the work of others with no indication that it is not your own - is frowned on by our community, and may result in your answer being down-voted or deleted. The original content was posted here, as it seems, given the date of the article.
    – Firelord
    Nov 24, 2018 at 21:26

Not the answer you're looking for? Browse other questions tagged .