1

I am trying to host a Wordpress site on my old Android phone, but so far I have been unsuccessfull...

I tried with KSWEB and Ulti Server, extracted the Wordpress.zip in the sdcard, and when I try to connect to the server I am getting error with the database...

Error establishing a database connection

Does it also has to run some other SQL server on the phone for everything to work?

I really don't know what am I doing, and there aren't any good explanations on the internet, so please help me

3

Wordpress requires a database to run.

After installing KSWeb, you will need to create a database for Wordpress. To do this:

  1. Open KSWeb.
  2. Go to Tools → select phpMyAdmin (it will install).
  3. Open Chrome browser.
  4. Go to localhost:8000 (to connect to phpMyAdmin).
  5. Select the Databases tab.
  6. In the box below the label Create Database enter wordpress, select create. Your wordpress database should now be created.

Now wordpress needs to be setup.

  1. Move your wordpress folder (unzipped) to /mnt/sdcard/htdocs/.
  2. Open a browser and go to localhost:8080/wordpress. It will ask you to setup your database connection.
  3. Enter root for the username and clear out the password field (you can leave everything on the default settings).
  4. Select Submit.

It should now connect WP to your database.

Thought about using a Raspberry Pi? I've setup several Wordpress Sites on the Pi (with MySQL) and you can set it up with your network for local website hosting.

References: Wordpress - Do I need a database

  • so can I host some other website, made with different platform? I want it to be on my phone – Sartheris Stormhammer May 6 '15 at 21:26
  • or how can I run a database server along with the other server? – Sartheris Stormhammer May 6 '15 at 22:16
  • 1
    See the modified answer on setting up everything – D. Gibbs May 7 '15 at 15:47
  • 1
    Can you access your WP server on the same network (the LAN) that your phone is on (e.g. 192.168.1.8:8080 on your broswer from a different device)? Are you specifying the port when connecting from outside? Are you connecting from a different public IP than your phone is on? There will be issues if connecting from the same network. What is the error msg that you are getting? – D. Gibbs May 7 '15 at 19:25
  • 1
    I did it, all I had to do on the router was forward the ports like this: 8000 > 8000 instead ot 8000 > 80 and so on – Sartheris Stormhammer May 7 '15 at 22:00
0

It is very simple just like installing Wordpress on any other web server. As above said by other Pals the KSweb is only on which works for me. So , I do recommend the same. Here are some steps to follow:

  1. Go to Google Play store and search for KSWEB.
  2. Install the KSWEB server which comes with Lighttpd server, Nginx, Apache, PHP, MySQL, msmtp, Web Interface,  KSWEBFTP, Editor and  Scheduler.
  3. Open the KSWEB Android Web server app and enable the Lighttpd, Apache web server, PHP and MYSQL.
  4. Go to Wordpress.org and download the Wordpress CMS files.
  5. Now open the file manager move the Wordpress.zip folder to htdocs and extract it there.
  6. Make sure the KWSweb is running in the background. Go to the browser and point to 127.0.0.1:8000/wp-admin.
  7. Follow the rest of the process of the guided Wordpress CMS interface.

Reference: Wordpress on Android KSWEB web server with screenshots

  • Isn't this, absent the varied verbiage, the same as the 3 years old, accepted answer? – wbogacz Oct 16 '18 at 13:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.