10

Please be patient for me to explain the situation. This seems to be an odd case to me, but it could happen to everyone using Android.

I make this specific to Samsung Galaxy S5 because this problem won't happen to my older Androids 2.x.x as they have a different structure in Contacts. But it does happen to my mom's Galaxy whatever. So it is likely to happen to Samsung phones, and/or to Android 4.x.

To reproduce the error:

  1. Add a phone number into your phone contact, which both your phone and that number have WhatsApp account. (You may use an existing number also.)
  2. Check in the Android Contacts, under Connected via, there should be both a mobile phone icon and a WhatsApp icon. When you click on the WhatsApp icon, you will jump to the WhatsApp chat. On the far right, there is a chain icon to link/unlink contacts. enter image description here
  3. Delete that contact. You will be prompted by a Delete contact alert box saying You can't delete contacts from read-only accounts, but you can hide them in your contacts lists. Click OK.
  4. Add again the same phone number.
  5. Now you can still send WhatsApp messages to that number, and the name (e.g. Mary) you added in the Contacts is showing in WhatsApp also. But the WhatsApp icon next to the mobile phone icon in Contacts does not show up again. You may try to click the chain icon hoping to link back the WhatsApp contact. But you will not find it.

For now, I have an idea that, while adding the phone number in step (1), Android detected there is a WhatsApp account for that phone number, so two contacts are created, one for telephone and one for WhatsApp, and the two contacts are linked to each others. This can be verified by unlink the contacts after step (2) - use another phone number for a try. When we delete the phone contact in step (3), Android actually needs to delete both the telephone contact and the WhatsApp contact. While the WhatsApp contact is managed by WhatsApp, it is read-only to Android. So Android cannot delete it. Android hide it instead, as the alert message says. If we want the WhatsApp tiny icon back in step (5), we have to unhide the WhatsApp part of the contact.

So here comes my question: How to unhide WhatsApp contact in Samsung Galaxy S5?

Before asking, I have searched for the solution:

In post #12 here, KolorIjo gave a solution that removing the WhatsApp account in Accounts and Sync can bring back the hidden WhatsApp contacts. This is verified to work by the_new_mr in post #18 and 10secsofsummer in post #19.

However, in my Galaxy S5, there is not a remove/delete option for the WhatsApp account in Settings > General > Accounts. In addition, I have a similar concern with beherat in post #20 that if removing the WhatsApp account delete all chat histories.

In another forum, anony1 in post #11 is providing similar solution, but the Google link is pointed to somewhere else.

Most likely, removing (and re-adding) the WhatsApp account is the way to go. However I am not able to do it in Galaxy S5. I am wondering Clear data for certain internal Application might have the same effect. But I do not want to mess up my phone, nor any of yours. We will be altering an internal App. So I am asking if anyone got the solution, or any experiences to this.

Another try would be uninstalling the WhatsApp app (and re-installing). But it is not so handy to me, considering I am having 3GB+ of chat/media history. And yet from certain forum (I forgot the source) said it will not bring back the hidden contact.

0

Go to the hidden contact from the phone contacts list, at the bottom you'll find a button saying "add to my contacts". That should resolve the issue.

I had the same scenario with one of my contacts, and spent a lot of time looking, and just by chance found that button.

0

Source: WhatsApp FAQ - Why are my contacts not displayed in WhatsApp?:

If your friend does not appear in the WhatsApp Contacts list:

  • Ensure that your friend is using WhatsApp Messenger.
  • Make sure that you have your friend's phone number in your phone's address book. If they live in a different country, make sure to save their number in full international format.
  • Make sure that you have the latest version of WhatsApp. You can download it here.
  • Make sure you have allowed WhatsApp to access your phone's contacts in your device security or permission settings.
  • In your phone's address book, make sure that all contact accounts (i.e. SIM, Google, Phone) are set to "visible" or "viewable".
  • In your phone's address book, ensure that all contact groups (i.e. Friends, Family) are set to "visible" or "viewable".
  • We recommend that you make your contacts "not visible" and then "visible" to force a refresh. After doing this, open WhatsAppContactsMenu ButtonRefresh.

Alternatively, you can choose to show all your contacts, not just the "visible" ones. To do this, go to Menu ButtonSettingsContactsShow all contacts.

IMG:

0

Try to resync whatsapp from settings, steps below: (This may vary per device.)

  1. Go to Settings > General > Accounts > Whatsapp.
  2. Untick the option (shown in screenshot below).
  3. Reboot your device.
  4. Again go to Settings > General > Accounts > Whatsapp.
  5. Re-enable the sync option of whatsapp.

Screenshot of the option in settings:

Screenshot of the option in settings
Click on image to enlarge
Hope my answer helps!

0

On my Samsung Galaxy Note 3 with the Touch Wiz flavor of Android, Samsung's Contacts app (which is horrible) allows you to DISPLAY contacts from one or all accounts.

When I recently installed the Whatsapp app, it changed my Contacts setting from DISPLAY only my Google account contacts to DISPLAY "all" account contacts.

If this happened to you, then go to the Contacts app > Settings > Contacts > Contacts to display > and change from ALL to the account you want to use.

0

I ran into the same problem recently on my Moto G running Android 5.1. The solution is rather simple but took some time to figure out.

  1. Send a text to the number from WhatsApp if you do not have a chat opened currently with that number.
  2. Open contact>Edit>Separate.
  3. Now that the contact's info is separated, go to the one containing the phone number (the one that's missing its WhatsApp link) and delete the contact.
  4. Open WhatsApp, the chat with the number will still be listed but wont show any name because its not in your contact list anymore. Open the chat>Add to existing contacts. DONE! The WhatsApp will have reappeared.

protected by beeshyams Aug 22 '17 at 18:28

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.