1

I had a LG Nexus 5 running Android in developer mode with the "Show touches" option enabled. Suddenly, while holding the phone steadily in my hand, the device registered tons of touches in the top of the screen, and I decided to turn it off immediately.

Now, after a reboot, the touch screen does not respond at all (not true; very rarely responds in a weird manner, that I can not reproduce). Everything else is working: volume buttons and power button.

I have tried the following:

  • Rebooting (obviously)
  • Restoring to factory settings (which is why I am now stuck on the "Select language"-screen in setup)
  • Clearing phone cache
  • Clearing the sim tray (has always been empty, but I tried ejecting and taking back in)

I always updated the software to the newest version available.

I have not yet tried pulling the battery out and in again.

Any ideas?

Update 1:

I have now tried pulling out the battery and re-inserting without any luck. I also installed Kitkat (version 4.0 from https://developers.google.com/android/nexus/images). Still no response.

  • 1
    Might be a hardware problem. I suspect digitizer. – samnaction Jun 14 '16 at 11:37
  • I agree with samnaction. You can get the Nexus 5 for $80 on ebay which is crazy cheap IMO. – William Feb 19 '18 at 18:44
0

I had a similar problem. Dropped my Nexus 5 last night with screen facing downwards. There was no damage to the LCD and its power and volume buttons were working fine too. However phone stopped responding to any touch. I suspected its digitizer was broken. So I googled for a solution and whacked the screen a few times as suggested on few of the forums. Also came across a suggestion from someone who had a similar problem to keep it in a freezer for 30 seconds. Alas phone remained adamant and refused to embrace my touch.

I checked with LG service centre for the cost albeit it was a too expensive proposition to replace LCD and digitizer (apparently in Nexus 5 its one unit and in case of damage to either component, you need to go for both). With nothing to lose as a last ditch effort I kept my phone in the freezer again and forgot about it for an hour or so. Voila that did the trick and phone is alive again and working like a charm!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.