I'm trying to remotely debug Chrome on my Samsung Galaxy Note 4, but I can't seem to get it working.

Note - to eliminate a device problem I have also tried to use an HTC One M8, but that also would not work.

Having reviewed the requirements from the Chrome remote debugging page -https://developer.chrome.com/devtools/docs/remote-debugging - I believe I meet all of the requirements -

  • Mobile device - Chrome 42.0.2311.111 (Lollipop 5.0.1)
  • Device used for debugging - Chrome Canery 44.0.2394.3 (Windows 7)
  • USB Drivers - Downloaded and installed from the Samsung website

Both devices are connecting to my laptop without issue, and I can transfer files between the two, however USB debugging is not working.

According to the above guide I should see a notification entitled Allow USB debugging? However, this notification is no where to be seen, and consequently the device inspector (chrome://inspect/#devices) is reporting no devices detected.

I've found many similar questions that advise the user to focus upon the USB driver, however I have ensured that I have my manufacturers latest version installed and I have had no success.

Is anyone able to advise on what I may try next?

Edit - I forgot to mention that I have also looked in to downloading the Google USB driver - http://developer.android.com/sdk/win-usb.html#download

However, I'm running Windows 7 x64, and it appears that these drivers are only suitable for x86 installations.

I've now also downloaded the Universal Windows ADB Driver Universal Windows ADB Driver as recommended on this site, but still no joy - USB Debugging is not showing in ADB devices

I have also installed the ADB plugin for Chrome Canery, but once installed the plugin notifies you that it is no longer required.

  • I had it going with a Huawei mobile, but not a samsung mobile, no matter what I did...
    – Ayyash
    Commented Jul 12, 2016 at 14:49

2 Answers 2


I found the missing pieces of the puzzle were installing the Java SDK & Android SDK.

I came across this because I couldn't connect to the "adb interface" - the Android remote debugging instruction page never mentioned installing an SDK, so I Googled "how to set up adb interface", and I found this page on How To Geek.

After installing the Java SDK & Android SDK, I was able to detect the device using "adb detect", and then Chrome was able to detect the device on chrome://inspect.

Prior to installing the Java SDK & Android SDK, chrome://inspect would not detect the device.

The version of Chrome Canary I was using was 48.0.2547.0 (64-bit).

The fact that the Java SDK & Android SDK install fixed the problem contradicts Google's own advice here:

You no longer need to configure ADB or the ADB plugin to debug remote browser tabs and WebViews. Remote debugging for Android is now part of the standard Chrome DevTools.

  • Excellent work! You saved me a lot of frustration. It's all too easy to assume that an android developer would have the android sdk installed and forget to test what happens when they don't. Commented Feb 13, 2016 at 23:17
  • the trick was tomake sure adb was in the path (environment variable) Type adb in command promptand see if the command is recognized. If not... there is your problem.
    – Ced
    Commented Oct 13, 2016 at 0:51
  • Trying to debug a Samsung Galaxy S7 from Windows 8.1, simply installing the Android SDK worked for me, and I didn't have to do anything else. I had already had the Java SDK and a Samsung USB driver installed for some time.
    – Emma Leis
    Commented Nov 21, 2016 at 1:45

Trouble Shooting (From the webpage)

I can't see my device on the chrome://inspect page.

  • If you are developing on Windows, verify that the appropriate USB driver for your device is installed. See OEM USB Drivers on the Android Developers' site. Verify that the device is connected directly to your machine, bypassing any hubs.
  • Verify that USB debugging is enabled on your device. Remember to accept the USB debugging permission alerts on your device.
  • On your desktop browser, navigate to chrome://inspect and verify that Discover USB devices is checked.
  • Remote debugging requires your version of desktop Chrome to be newer than the version of Chrome for Android on your device. Try using Chrome Canary (Mac/Windows) or the Chrome Dev channel release (Linux) on desktop.

If you still can't see your device, unplug it. On your device, select Settings > Developer options. Tap Revoke USB debugging authorizations. Then, retry the device setup and discovery processes.

Things to check*(From the top of my head)*:

So you've turned on USB debugging in developer settings on your phone, correct? If it is turned on it will show up on your phones notification bar, if it doesn't show your phone doesn't have USB debugging on.

If it is on but chrome cant detect it try running "adb devices" from windows command prompt to see if your computer is detecting it. If the computer is detecting it you that adb is working, thus a problem with chrome. If it doesn;t detect it you know that windows is also not detecting adb, thus install the correct drives and turn off adb and then back on (if necessary) and try again.

However, I'm running Windows 7 x64, and it appears that these drivers are only suitable for x86 installations.

You can install the drives on your windows platform as it is 64-bit (64-bit can and will run 32-bit code (x86 is what you called it in your question)), so install the drivers and try again.

Install Drivers

To check that windows can communicate to the adb interface:

  • Make sure the phones adb setting is turned on, and connect the phone to the computer
  • Navigate to the windows device manager.
  • If everything is correct (the correct drivers are installed, phones adb is turned on and the phone is communicating to the computer) you should see "Android ADB" on top of the device managers list.
  • If it isn't, install the correct drives for your phone and make sure the ADB setting is turned on in your phone

If none of this works, contact me and I will try help you as much as I can. Hopefully it was just the drivers and nothing else.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .