2

I'm using my phone as more of a tablet computer and less of a phone (I'm not using cellular radio, only wifi Internet), so I didn't put a SIM card in it.

The issue is - the notification that I don't have a SIM card in my phone always shows up in the notification bar:

screenshot of issue described above

I am already running the phone in airplane mode and then enabled wifi, but the issue persists. I also tried force stopping the 'Phone' app and it does remove the notifications, but it comes back after phone restart.

How do I disable or hide these notifications permanently?

The phone is a Lenovo A536. Android version is KitKat 4.4.2.

  • 1
    The only method for a non-rooted device I found (here) is to use a non-working SIM card in those slots and then disable those SIMs from SIM Management in Settings. Otherwise, the other methods (some listed in answers) requires root access. – Firelord May 10 '15 at 18:03
  • For readers: GravityBox [KK] can do it. It requires Xposed Framework and a rooted Android. – Firelord Feb 17 '16 at 5:34
1

I've recently rooted my phone and installed NotifyClean (requires the Xposed Framework). I've set it to block the Mobile Data app's 'No SIM card detected' notification:

screenshot of NotifyClean

I've previously tried to fix this issue with Notifications Off but it stops working after a device restart.

0

The only way I can think of is to hide all of system UIs notifications. To do this, you need root access and an app called Notifcations Off. Once you've installed Notifcations Off, you can just turn off System UIs notifcations.

  • I've rooted my device, installed Notifications Off and blocked the 'System UI' app from notifications, but I am still getting the 'No SIM card detected' notification. – galacticninja Feb 21 '16 at 10:30
0

Option 1: You may try turning off "Show Notifications" check box by visiting Setting-> Apps -> All Apps.

From here, you can select the app sending this notification and un-check the "Show Notifications" check box.

In case if you are not sure which app sending these notifications, you can LONG PRESS the notification area itself, and system will show you "App Info" bubble. Click on it to navigate to Settings of that app.

Once you are in settings, you may turn off Notifications by un-checking the "Show Notifications" check box.

Below is the screenshot of another App to guide you to do this.enter image description here

Option 2: In case if above steps don't solve the issue, you may need to use Xposed Framework You need to Root your phone for this to work.

Read about the Xposed Framework and how to install it from here. Verify if your handset is supported. You may want to look at : Status Bar Icon Hider

protected by Community Aug 19 '15 at 16:46

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.