1

Sir when I open many apps it shows the app would'nt run without google play service which is missing from your phone So I tried many versions of google play service but I could not instal any from them it shows installing but at last always it shows application not instaled and android version is 4.0.4 unknown source in open I also tried to instal it from google play store but it shows insufficent space but I have space in my phone sir please help me...

  • 1) IDT you can install Google Play Services by using package installer of Android. Mostly, the Gapps(Google Apps) zip file has to be flashed into system from Recovery to install core Google services as System apps and services. 2) Having space in your Internal Storage is different from having space for app storage (/data). You can add(edit) as well as look into questions in insufficient-memory tag. – Firelord May 12 '15 at 12:08
  • On a side note , consider editing the title since it doesn't attract a reader to answer here. Also, purge "Sir" since there is no mandate that the reader/answerer would definitely be a male, not to mention there is no need to mention it at all. – Firelord May 12 '15 at 12:11
  • See: How can I install the Google Apps Package (Play Store, …) on my Android device? for the play-services issue, and our insufficient-memory tag-wiki for your space issue. – Izzy May 12 '15 at 14:33
1

The (non-google play) installs are failing because you have insufficient storage space.

You may think you have enough space, but due to the partitioning of your device, and because you can't fill it up completely, you don't.

I'm assuming you have an older version of google play services installed.

You need to delete some apps, simple solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.