2

I have a brand-new Moto X (2014) running Lollipop. I have two gmail accounts, me@gmail and work@gmail. While I would like to be able to check both accounts for new messages on my phone, I only want my me@gmail contacts to sync to my phone; not the work@gmail contacts, as some are sensitive and my employer would take issue with them being available on my personal phone. Short of manually deleting those contacts one by one (and there are several hundred), is there another solution? Thank you so much!

  • In my device running CM12 (lollipop), I can go to ROM's default contacts app, choose "Contacts to Display" and uncheck the Gmail account whose contacts I don't want to see. Let me know if it works for you as well. Otherwise, what Dipika answered is also good. – Firelord May 13 '15 at 7:18
4

Go to Settings-> Accounts -> Google -> Select Account(whose contacts you want to Sync) -> Select Applications which you want to Sync(Contacts)

  • Also make sure you don't have any active filters. In the contacts app press the 3 dots upper right corner, select filter and check all you want to see. – publicJorn Jan 30 '16 at 14:24
  • 1
    But it looks like the already synced contacts aren't removed – Magnetic_dud Apr 20 '16 at 12:40
  • 1
    @Magnetic_dud Delete the Google account to remove all the contacts from that account – Kidquick Jul 7 '16 at 1:01
0

With Android 7, in addition to @Dipika's helpful suggestion, I had previously configured a second account and found it useful to delete Contacts application data to reset the default account:

Go to Settings -> Apps -> Contacts -> Storage and press the "Clear Data" button.

Then when you next add a new contact, you should be prompted for which account you want to be the default. Select the account that you have configured to sync.

0

Also, u can do this ,

Go to Gmail-> Click Settings-> Click on the account which you don't want to sync in contacts and whatsapp->Click on Right Menu Icon (xyz @gmail.com |) -> Select Manage Accounts-> From Auto Sync, Deselect the Icon.

Now go to your contacts and check. It worked for me

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.