2

I have at one point chosen Truedialer as the default app for opening contacts.

I would now like to set Google Contacts as the default app.

I have cleared the Launch by default setting for Truedialer.

However, when I click on a contact (found using searchbar) I get a dialog stating

Open with View contact
                  [JUST ONCE] [ALWAYS]
Use a different app
Contacts

Open with dialog

(View contact is the Truedialer app, Contacts is the Google Contacts app)

Now, I can choose View contact as ALWAYS, but I cannot choose Contacts as ALWAYS, I can only click it to use it once.

This same dialog shows up every time, no matter how many times I search for a contact. It only gives me the option of setting View contact as default, never Contacts.

How can I set Contacts as default?

3
  • 3
    The app that is shown at the top, is the app you used the last time to deal with contacts. If you use Contacts now then next time Contacts is on top and you can tap Always. I know, it's a bad design decision.
    – GiantTree
    May 17, 2015 at 10:54
  • @GiantTree unfortunately, that is not the behaviour I get. I have opened the Google Contacts app and then immediately after attempted the above search and select operation. The result is the same. I have also chosen Contacts in the above dialog and then repeated the search and select operation. Still the same behaviour. May 17, 2015 at 16:06
  • I have the similar issue where I cant not see supported apps in "Use a different app" section that was previously visible. It happens to me after upgrading to Android 6 May 29, 2016 at 6:47

1 Answer 1

0

I had the same issue with a widget.

For me the following worked:

Go to Settings->Apps and click on the menu button (the three dots in the right top) and select Reset app preferences.

This resets a lot of stuff, but I was able to select Alwaysfor the right app again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .