13

I have LG G3 with android 5.0 lollipop and I want to connect it to my laptop with windows 8.1 OS (For using unity remote).

When I connect my phone I can access to storage but I can't see my device in adb.exe. I tried many solution like this and this but nothing work for me.

For now in developer mode I checked these:

  • Stay awake
  • USB debugging
  • Allow mock locations

And I installed the driver from lg website. This is output for adb usb command:

shell@g3:/ $ adb usb
adb usb
error: device not found

Actually I really confused because I think it recognize my device and show g3 name but I don't know why it can't show my device name in attached device!!!

This is windows command prompt screenshot: adb

Without lg driver installed, my device in device manager is like image below and when I try to update the driver using Android\android-sdk\extras\google\usb_driver it say: Windows could not find driver software for your device

without lg driver

And when I install lg driver, my device is like image below and again i can't update driver and it say: Windows has determine the driver software for your device is up to date

My device with LG driver installed

  • It looks like you already are using your device through ADB. The normal Windows command prompt looks like C:\Users\hossein>, while yours is shell@g3:/ $. That's what a Unix prompt looks like, and that means you're in your device's shell interface. If I am correct about this, then the reason your adb devices command doesn't work is because your phone is looking for other phones connected to it - of which it finds none. – aureljared May 19 '15 at 12:02
  • @aureljared I didn't get it, Why my phone need to connect to another phones? And what I need to do to solve this problem? – Yandirr May 20 '15 at 3:45
  • 1
    I don't think I made my point clear. :D Your phone doesn't need to connect to another phone. What I'm saying is that it's possible that you're already successfully using ADB to connect to your phone, because the screenshot you uploaded (shell@g3) looks like the shell of your phone. What commands did you enter until you got to that screen? – aureljared May 21 '15 at 2:07
  • Asking the same with different words: what is that "black screenshot" from? From a command-prompt on your Windows machine, or from a terminal shell on your device? The shell@g3 shows you are executing adb devices on the G3, not on your Windows computer. What happens when you execute adb devices from the Windows prompt? – Izzy May 22 '15 at 15:49
  • 1
    I think it makes no sense to explain it again in different words as you obviously have no knowledge about ADB. Please get yourself a little bit informed about the command you are using: developer.android.com/tools/help/adb.html. If you read what especially the command "adb shell" does you should get what was explained above :) – divided-by-zero Oct 19 '15 at 14:27
4

Go to Settings-->Storage-->Menu(3 dots in the corner) and tap USB computer connection. When there, make sure MTP and PTP are both unchecked.

  • Pardon me, but this is impossible to do on some phones that do not support charge-only USB computer mode, such as most Samsung phones post-Gingerbread. – aureljared May 19 '15 at 11:58
  • This does not work on my phone, where I am forced to have at least one of MTP and PTP checked. – Fang Jing Nov 24 '15 at 20:21
2

I had a hard time getting this to work with my LG G3 on Windows 10. Here's what worked for me:

  1. Uninstalled the LG USB Driver.
  2. Installed the Universal ADB Driver. (Thanks, @Lucia!)
  3. Restarted my computer.
  4. Plugged in my phone, went to device manager, and installed it manually as an "Android Composite ADB Interface".
  5. Switched the USB connection type on my phone from "MTP" to "PTP".
  6. Allowed USB debugging on my phone.

Success!

Note: Some of these steps may not be necessary, for example, just switching to PTP might work just fine, but I'm documenting what eventually did work for me, and I didn't want to take the time to experiment because if it ain't broke, don't fix it. :)

ADB finally haz phone!

  • Choosing PTP and enabling USB debugging was enough for me to get it working. (Not sure if PTP was needed, started working after enabling USB debugging) – Søren Ullidtz Jan 26 '18 at 8:33
  • The Universal ADB Driver worked for me. Except I didn't need to do steps 3, 4, or 5. However, I did need to perform an additional step: plugging the device into a different USB slot. (Before installing the universal driver I had it in slot 1, but after installation even plugging in and out didn't help; putting it in slot 2 finally made the Windows "new device plugged in" sound, which was followed a few seconds later by the accept-fingerprint popup on my phone, and then successful ADB connection.) – Venryx Jul 29 at 7:32
1

I was facing this problem for two days, and I solved installing the USB driver for my phone LG G3 on my Mac Yosemite. I downloaded the file LGMobileMacDriver_v5.0.zip and installed it and than adb devices just worked.

Before anything, just confirm that debug option are enable.

You can try to install the USB driver of your phone, maybe it'll help. Download Location for Driver http://www.lg.com/us/support-mobile/lg-LGD850

Best,

1

On windows I had to install this software: http://www.koushikdutta.com/post/universal-adb-driver After the installation android studio started recognizing my phone.

0

I had a similar problem with my Lennovo vibe. Installing the adb driver from here solved it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.