Does this command still work?

fastboot oem unlock

I ask this question because I am obviously trying to unlock my phone's bootloader and can't seem to auto-tab the option or see an entry for this particular option in the space documentation.

Can you confirm if this works? If so, please tell me why I can't auto-complete it like other options?

If it matters, I am unsuccessfully trying to unlock a Lenovo p780 bootloader.

  • also I noticed that whatever I type as options, it won't give any errors. So it could be possible that I am typing a non-existent command option? May 17, 2015 at 17:47

3 Answers 3


Depends on the model not all phones/tablets support OEM unlock. This a manufacture decision. For example some low end lg phones use a custom boot loader that wont even let you boot to it. Nexsus 10 tablets from google on the other hand support oem unlock. Newer androids have a factory reset protection mode that must be disabled for oem unlock to work. The setting for this is control by an "oem unlock" option within android. This option in and of itself does not unlock the boot loader it merely allows it to be done.


It still works, if you need to unlock your phones bootloader you will need the command

fastboot oem unlock

If you're running Linux you'll need

sudo fastboot oem unlock

I own the OnePlus One and this is how I unlocked my bootloader. You need to do this for every phone when you want to unlock the bootloader

  • When the command unlocks the bootloader any idea what it actually does? Is there a hardware register it sets? May 18, 2015 at 17:02
  • No it triggers a flag in the software here are some links about it: forum.xda-developers.com/wiki/Bootloader m.blog.laptopmag.com/… May 18, 2015 at 17:05
  • Oh my goodness, I just read back on this answer. I was so young back then, like 15, and didn't know it didn't always work. Nowadays I know better but yikes... Mar 31, 2019 at 18:56

Nah.!! personally ive tried unlocking lenovo p780's bootloader..it dosent unlock with fastboot.. although there is a fastboot protocol in lenovo it dosent actually let you unlock it...

but... fastboot oem still works ive tried it on 3 DIFFERENT PHONES..

if u want to unlock it, just root your phone through a playstore app while the phone is booted.. even if it is rooted partially..

then, download any recovery app..which lets you in-turn download a custom recovery.. then give root access to the app..it will install recovery.

Now, for the final part... boot into the custom recovery u've just installed .root through flashing supersu from there(optional) and then install custom ROM(if you want!!) happy developing!! :->

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .