4

I just updated my Galaxy S4 to Android 5.0.1/Lollipop. I don't like to use the drop-down spell check/autocorrect box; I prefer the one built into the Google Keyboard that displays as a line of suggestions above the keyboard. The drop-down displays over that line so I have to back out of it to tap a suggestion.

I had it disabled on Android 4.4.2/Kitkat and cannot figure out how to turn it off in 5. I've toggled all settings under Google Keyboard and Samsung keyboard to no avail. The only way I could find to disable it was to force close the Samsung keyboard, but unfortunately I can't permanently disable it.

Thanks!

Screenshot:

Screenshot of drop-down keyboard

  • I've given up and will just live with it...I don't think this option can be turned off in Android 5. – SpacemanSpiff Feb 12 '16 at 21:27
2

I managed how to disable the Lollipop's spell checker, (not one from keyboards as in other answers).

Just go to, SettingsLanguage & inputSpell checker then switch it off.

Already done ;)

1

On the Galaxy A 5, go to : Settings -> Language and Input -> Samsung Keyboard Settings -> and switch "Predictive text" to off.

0

Check if you have Google Keyboard installed in Play Store. This keyboard somehow done all the spell checking despite the fact that I couldn't find it in settings, I wasn't even aware I had it installed. After uninstalling Google Keyboard spell checking turned off. (not my advice, I checked it on http://forums.androidcentral.com/samsung-galaxy-s5/514492-spell-check-won-t-turn-off.html)

  • Well, it did turn off spell checking (the red underlines) but not the drop-down. Thanks! – SpacemanSpiff May 28 '15 at 18:02
  • To disable spell check you just need to disable Google Keyboard (GBoard - Google Keyboard). It works if you use different keyboard, for instance, SwiftKey (as I do actually). – oxied Dec 27 '16 at 0:47
0

The drop down bugged me for ages too as I would go to tap the correct word along the top of the keyboard and the drop down overlay would always pop up in the way and I would hit the wrong thing.

Here's how I solved it:

Settings > Language & Input > Google Keyboard (It was the 2nd option under Keyboard & Input Methods for me) > Gesture Typing > switch off Dynamic Floating Preview.

0

Samsung Note 4: Go to Settings → Controls→ Language and input, and make sure that default is set to Samsung Keyboard.

Under that, tap on Samsung Keyboard to open it. Scroll down, tap Predictive text to open, and move the slider (in the top right corner) to off.

Done.

0

Unfortunately I've come to the conclusion that, at least in Android 5 on my Galaxy S4, there is no way to disable the spell checker. I've been trying to just adjust my correction method to use the drop-down.

protected by Community Mar 2 '16 at 21:45

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.