1

I'm trying to connect to a DLink Router protected with WPA/WPA2. It's our home router and I can connect perfectly to it from laptops and desktops, Linux and Windows alike, even for my friends mobile(Android) it connect smoothly. But when I connect to it using my Android phone (Motorola Droid), I am always notified to "Sign-in to WiFi Network" after I've entered the WPA/WPA2 password. Tapping into the notification loads my ACT logging page, and after entering my credentials it says you are now logged in, but when I try to open any other site or even refresh this page it again ask me for my ACT credentials. Other apps that connect to the internet do report connection problems.

I checked my router setting, in which I have added my mobiles MAC address also in Interface setup->wireless->wireless MAC address filters, but it is not working. I have made encapsulation ISP as PPPoE and have entered my password there. Still not able to connect in my phone.

I am able to connect my phone in all in my friends place so for sure thire is no problem with my phone. what else is required..?

  • On your Android device you go to Settings › WiFi, and long-tap on your AP's entry, selet to edit it, tick the "advanced" check-box, and verify the settings there: is it using DHCP, or a fixed address? In the latter case, does it match with your network, and has the correct gateway set? In the former case (DHCP), can you verify your IP/gateway (IP e.g. via Settings › About phone › Status) and see if it matches? Also, having the IP address: can you ping that from your computer? – Izzy May 27 '15 at 9:52
  • Have you tried setting the ACT login as a proxy server? – MadMrCrazy Dec 29 '15 at 7:11
-2

I fixed mine by putting a static IP. I chose a IP in my network range and it work

Not the answer you're looking for? Browse other questions tagged or ask your own question.