Recently I have downloaded two games:

  1. Deer Hunter
  2. PreHistoric Worm

But after that I have my browser which keeps redirecting me to http://ad.adsmatte.com

It is happening every time I load the page – after few seconds, it automatically gets redirected to this AdsMatte and doesn't go back to the previous page, even if I press the Back key.

In an application like WebMd, when I load the app, after few seconds it is covered with a full screen ad whereas it used to display the options menu. This is blocking my view and I cannot see what is being displayed by the application.

The WebMd app which is showing an "Update Your Browser" message with a "Install Now" link to Play Store (click image for larger variant)

I don't have Opera and it still tells me to update my Opera browser.

I closed the application and retried it, and again it is displayed with some "Warning your HM1S is affected with Virus" and starts vibrating.

Note: Please avoid anything like this post suits well on MIUI/forum, I have already asked there and got a very immature answer as to disable Java Scripts even after seeing my below screenshot.

[Update] I have tried using mobile data and now it does not redirect so it's more of the modern problem the app are clean

  • which browser do you use..opera or chrome or something else?
    – Lucky
    May 19, 2015 at 16:34
  • It is UC Browser with Ad Blocker,Pop blocker enabled
    – user285oo6
    May 19, 2015 at 16:35
  • your device may not have been affected by any kind of virus. i have used UC browser and it suggested to download unwanted apps and alerts like these..so i suggest you use chrome or opera browser..the redirection problem might be due to an extension(add-on) you have installed diable or remove all your addons and reset the browser settings..
    – Lucky
    May 19, 2015 at 16:56
  • 2
    For a starter, please take a look at our malware tag-wiki and follow the first-aid links. As you already described the issue started after installing those apps: Have you tried to remove them? Did that help? And btw: where did you install those apps from? // @Lucky no such thing like a "virus" on Android ;) But malware indeed, yes. Which is why I've added the malware tag to the question.
    – Izzy
    May 19, 2015 at 17:11
  • Community bump prevention: this question was closed because the question seems to have been abandoned (OP hasn't visited the network for more than 4 years, and no answers have score above 0). If anyone can evaluate the existing answers, feel free to vote accordingly and reopen the question (or mod-flag the question requesting for reopening). For anyone else having the same issue, please post a new question and refer to this question as additional context.
    – Andrew T.
    Aug 19 at 3:31

1 Answer 1


Based from the same problem on AskUbuntu, this is not OS-dependent, but an attack to the router. Try hard reset the router.

This does not appear to be an OS related issue. I would recommend you to read this http://www.quora.com/How-do-I-stop-AdsMatte-spam-popups-and-ads

Basically it is an attack on/via your router. You should hard reset it. A lot of computers on my intranet got affected. I got rid of it that way.

If it still fails, from Security.SE, try checking & fixing the DNS address both on router and Android device.

If your router is affected and you're facing different issues on your devices (Android has no ads, computer does) may check/change your DNS settings on both devices and on the router.

I think your Android phone uses a different DNS server as your PC. Your PC probably uses your router as DNS Server (e.g. and your Android uses a 3rd party DNS like Google (, or OpenDNS. For this behaviour check: this answer on Super User

To clean up your router, you may have a look at: this answer on Security.SE

To check DNS settings on Android:

  1. Open Settings - Wi-Fi
  2. Long-press the access point, select Modify network
  3. Turn on Advanced options
  4. Change IP settings to Static
  5. Check/set the DNS 1 & DNS 2 to Google DNS ( and or other trusted DNS server.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .