1

After my Samsung S5 has been updated to Lollipop (5.0.1), notifications re. new mail, text, facebook, etc. don't show on my lock screen. The only thing showed is my network operator.

Now I have to unlock every time to see why my phone made a beep/sound. Any way to bring the info back?

2

Go into settings and then into Sounds and notifications. There should be an option called "While locked". Tap into that option and select from the list to show notifications on the lock screen.

  • That middle option is not available on my nexus 5 and choosing "show all content" just doesn't work. I'm on android 6. – Startec Aug 25 '16 at 4:37
  • @Startec - See my answer below. – sancho.s Mar 4 '17 at 15:31
0

I am using Android 6.0.1, so this may not work for some. I used it for WhatsApp, see comment below.

Go to Settings -> Notifications -> ADVANCED (at the top right) -> (Choose the app you want) -> (tap the little info icon at the top right) -> Notifications -> More settings -> Popup notification -> Always show popup

(see image below). I tested that this setting is what makes the difference, since setting Only when screen "on" did not show notifications in locked screen. But this is a setting from WhatsApp, as I could access it from within WhatsApp as well.

I could not find a setting from Android for doing this (neither on a per-app basis or as a global setting), so I wonder whether it is up to each app to have a setting like this. This makes this post partly an answer and partly a question!

Note: In Android 6, settings for Sounds is separate from Notifications.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.