1

I have a Verizon Motorola Razr HD Maxx, running the latest firmware (182.46.15.XT926). My phone was dropped and the screen shattered about 6 months ago. The Razr was powered off and left alone while I switched to an older phone until I could find the time and money to get a screen replacement. Having just done so, my phone is now in mostly working order. I can browse on 4G and make/receive test messages and calls.

However, the date/time on the phone are completely inaccurate. It is currently reporting the date as 3/15/2015, and the time as 6:52 as of the time of this post (while it is 10:56 AM EST, 5/21/2015 in reality). Manually attempting to change the time does not work - After modifying the time and selecting done, the change does not persist.

I do not appear to be the only one with this problem - others have reported it online (see here and here for example), but no solutions have been posted which worked. I am curious if anyone here has input as to a solution.

This is a huge impediment for me, since many apps rely on the time and any SSL cert checking will fail due to the incorrect date, preventing access to Google Play.

  • What time settings have you tried? Have you set it to manual, or let it auto-update from network? Is the device rooted? – Izzy May 21 '15 at 16:38
  • The devices is not rooted - totally stock firmware, just with apps installed via google play (nothing sideloaded). I have tried setting the time to manual (changes don't stick for date or time, though timezone will stick and adjust the displayed time by the correct number of hours). Enabling 'Automatic date & time' to use network provided time does not appear to do anything. I have done so with and without the sim, rebooted in and out of safemode, and every combination thereof to try and get the phone to correctly pull time from the network. – user2093082 May 21 '15 at 17:15
  • 'Automatic time zone' correctly identifies my time zone as eastern when it is enabled (e.g. i manually set to mountain time, enable automatic time zone, and the phone switches to eastern) – user2093082 May 21 '15 at 17:18
  • OK, that limits the possibilities. I don't see how that could have been caused by the screen broke (if it wasn't there before), but that might be coincidence. A firmware update might solve it. If there is no such, ClockSync app might help; though without root it cannot adjust "to the second". Still worth a try. – Izzy May 21 '15 at 19:14
  • Any suggestions on getting ClockSync installed without access to google play? An inaccurate clock means I can't do anything over SSL – user2093082 May 21 '15 at 19:15
0

OK, software can't solve a hardware problem. Took the phone apart and disconnected the battery for ten minutes. Reconnected the phone and the clock reverted to when the device was manufactured (i'm guessing, was 2010). But, could now be adjusted as one would expect.

0

Well I"m trying to spread the word in as many related threads as possible. I had this exact same problem and thought it was related to an update as well. Turns out it was a hardware failure of my phone. I'm not sure if links are permitted but it's easier to just link to the thread that eventually led me figuring out the issue. If it gets bumped I will describe my scenerio:

Thread that helped me at AndroidCentral

  • 1
    Quote the relevant steps from that article please. – Aaron Gillion Mar 5 '16 at 0:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.