1

I have one week old S6 and now tried to use adb.

I unlocked developer mode, enabled USB debugging, connected to usb and nothing happened. adb devices shows empty list, lsusb on mac and linux as well as mac's "system information" app doesn't see any new usb device when I connect the phone. Nothing happens in dmesg too.

The phone displays "charger connected" notification. No mtp/ptp notification appears.

I tried to use different computers (two linux boxes and one macbook), different cables, nothing. Other android devices (such as old note2 and some noname stuff) works well.

I tried also other person's S6. Result it the same so I don't think it is some kind of damaged socket or so on.

What's going on? Am I missing something? Maybe some security setting prevents USB from working?

UPD

This doesn't look as a "driver" issue at all. lsusb shows all usb devices even if the system doesn't know how to deal with them.

  • 2
    You downloaded and installed the USB driver appropriate for your desktop computer(s) from Samsung site? – wbogacz May 21 '15 at 17:56
  • 1
    It appears that Samsung has done something special, meaning you need extra drivers in addition to the standard ADB ones. Put your phone's model number in samsung.com/us/support/downloads and scroll down to Manuals & Downloads. For at least one model, it looks like the drivers are Windows-only; if you can't access a Windows machine you could try using WINE (winehq.org), although udev may stop you. – user43185 May 21 '15 at 18:25
  • 2
    Actually, AFAIR, even devices unknown for the system appears in lsusb so it is not a "drivers" problem. – Equidamoid May 21 '15 at 19:13
  • 1
    If you have a custom recovery (or know someone with one), does the phone show up in adb when booted into recovery? – keepcalm May 22 '15 at 8:34
  • My device (not Samsung but some other) tends to behave in the similar fashion occasionally. In my case, the system detects nothing except that the charging LED shows power status. The solution that works for me is to keep rebooting the device multiple times, until it goes away. IDT whether the issue is with the socket (1.5 yrs old device) or the cable, but the issue withers away. I know it makes no sense, but you may try this technique it nothing good works. // I once even had to restore nandroid backup. – Firelord May 29 '15 at 1:09
3

I was getting very frustrated with my Samsung Galaxy S6 and my new Dell Precision M3800 and USB connectivity. Apparently the S6 is not fully compatible with USB 3 connections. I could not get it to connect (other than charging) to any of the 3 USB 3 ports on my laptop (no usb 2 on the new Dell). It connects fine to my older laptop (USB 2), so I decided to try connecting a USB 2 hub to my new Dell and the phone to the hub, and it works! So, Samsung, please fix this!

  • This also worked for me. – Damon Aug 15 '18 at 18:54
2

Sad but true, it's a hardware issue. As far as I understand, the board containing usb socket needs to be replaced.

PS: Also the worldwide warranty that I was promised to have in official (listed on samsung.com) retail shop doesn't exist.

1

I had this same problem. Samsung buried the option to turn USB debugging on deep inside the Settings menu. You have to enable it in order to use ADB with the S6 (or any other Android device)

Have a look here.

  • Nope. This is a hardware issue. Authorized service center confirmed it but refused to perform warranty repair. – Equidamoid Sep 17 '15 at 16:21
  • Dood its not samsung its with every Android phone. Samsung didn't buried that thing. – Dr. Andro Mar 11 '16 at 9:32
0

It's not a hardware issue, or a computer driver issue. It's whatever the USB "driver" is on the S6 itself, because a factory reset resolves the issue.

I can't figure out what it is that breaks it, whether it's a setting change or an app getting deleted. If anyone's aware I'd love to know.

  • Hard reset had no effect, that was the first thing I did. – Equidamoid May 30 '15 at 6:51
0

I was having similar issue with my S6 Edge(+). Found to be junkie usb cable. Switched to a quality cable and device showed up.

  • 1
    OP on the question noted that they already tried with different cables and that didn't work out, so I'm not sure how this answer would help. – Firelord Jan 19 '16 at 0:02
  • Yeah, the only advice that may help for similar situation -- "Don't trust Samsung and their partners". – Equidamoid Jan 19 '16 at 19:17
  • I'm having a similar problem but my phone use to actually work when I connected it through USB. Maybe this is a software update issue? Sometime ago after updating I noticed the problem. – Oneezy May 3 '16 at 16:10

protected by Community Feb 1 '16 at 17:06

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.