2

Edit: This question was made when I assumed that apps put their web cache into the stock browser's own cache. This is not the case. Apps usually put this data into their own app_webview folder. I'll keep this question up though since Izzy's answer is a good one.


I have a Sony Xperia E3 running Android 4.4.2, and after using AppInventor for some time the inbuilt browser (aka the stock Android browser) has taken up a large amount of storage space with the cache.

Since the stock browser technically isn't installed I can't access the menu to clear the cache.

Is there any way to clear the cache without factory resetting/rooting?

1

As a side-effect of clearing all caches of all apps: boot into recovery-mode, and select "wipe cache". That wipes caches of all apps, but keeps your apps and data themselves intact.

If you have activated and available to use, there's a command doing the very same:

fastboot erase cache

This comes in handy especially for devices where you cannot access the .

Hint: you might be tempted to suggest adb shell pm clear com.android.browser for the very same purpose, restricting the purge to the specific app. Note that this is not only clearing the cache, but all the app's data as well. And it requires "elevated permissions" (i.e. ) to be executed – which is probably why it returned "failed" when you tried. The full command would then read:

adb shell su -c "pm clear com.android.browser"
  • I don't think that the phone has a recovery mode. I tried every button combo with no success. This proves that – MoonRunestar May 22 '15 at 18:05
  • Although I'm going to try and flash the new boot loader that Sony is providing now. – MoonRunestar May 22 '15 at 18:24
  • The latter will provide exactly that, as far as I've read: a pretty convenient recovery-menu. So following that update, you should definitely be able to follow the steps of my answer :) – Izzy May 22 '15 at 19:36
  • Just tried using Flashtool (by Androxyde) to unlock the boot loader so that I can flash the latest version to it. Turns out that my phone model cannot have its boot loader "officially" unlocked according to Flashtool, and the phone's dev menu. I'm not sure if I'm missing anything. – MoonRunestar May 22 '15 at 20:22
  • Argh, I just gave up and factory reset everything. I tried to use adb shell pm clear com.android.browser from my computer but every time it just said "Failed". – MoonRunestar May 22 '15 at 21:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.