0

I have a Samsung A3 with Android 4.4.2 (not rooted) and a computer running Ubuntu 14. I am trying to connect my device to my computer through USB to be able to perform some tests on it.

I have activated the USB debugging mode. But when trying the adb devices command, it keeps telling me the device is "unauthorized". Also, no pop-up appears on the phone which makes it impossible for me to authorize it.

Here is what I have already done:

  • I've updated and upgraded multiples times my ADB version
  • Installed mtp, mtp-tools;
  • Configured the USB access for the Samsung in /etc/udev/rules.d/51-android.rules:  

    #Samsung Galaxy A3
    SUBSYSTEMS=="usb", ATTRS{idVendor}=="04e8", ATTRS{idProduct}=="6860",
    MODE="0666" GROUP="androiddev", SYMLINK+="android%n"   
    
  • Even installed the PPA ppa:langdalepl/gvfs-mtp (usefull only in Ubuntu 12 and uninstalled it later);

  • Tried to find and delete some previous adb-key file, but there were none. (The device was never connected to that computer before.)
  • Changed Cables;
  • I also tried with a Samsung S5 under Android 4.4.2. The ADB command on those two devices works when on a windows machine.

Do you have any ideas as to why it does not work, or of any thing else to try out without rooting the device?

Thank you for your help.

0

You might be able to clear the list of authorized devices so the authorization list is reset to its default if it is in some kind of corrupted state right now. You can do this under Settings > Developer options > Revoke USB debugging authorizations.

Another thing that is frequently overlooked is rebooting: rebooting both your Android device and your computer might make it work. Another thing to try is connecting the device to your computer and then disabling and re-enabling USB debugging, my personal experience is that this fixes a lot of ADB problems.

Users on stackoverflow reported that switching the device to camera mode might work as well.

If all else failes, you can also try to manually authorize yourself on the device, using Flavios answer on Stackoverflow:

  1. Move the authorized key file: mv /data/misc/adb/adb_keys /sdcard/adb_keys_backup (you can also delete it if you want)
  2. Send your adb public key to the device (look in the ~/.android directory)
  3. Stop adbd using the command stop adbd as root
  4. Copy your key to the authorized devices list: cat adbkey.pub >> /data/misch/adb/adb_keys
  5. Start the ADB daemon again: start adbd (as root)
  • Thank you so much for you answer. Although i did mentioned it i had already rebooted both the computer and the device various times. I had also revoked the USB debugging authorizations a few times and tried switching it to camera mode without getting any results. I therefore wanted to try your idea to manually authorize myself on the device, but i just could not find the file either on the device or on the computer... – banana May 26 '15 at 9:35
  • In the end what worked for me was : 1. Entering root mode on the computer, 2. Killing all adb processes, 3. Disabling and re-enabling the Debugging 4. Using the "abd devices" command again. It felt really fustrating to loose so much time trying everything twice, just because i was not in root mode.. Thanks again for your time – banana May 26 '15 at 9:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.