1

I have tried to root my Nexus 9 using this guide: http://www.ibtimes.co.uk/how-root-google-nexus-9-unlock-bootloader-1473817, but now I'm stuck in an endless reboot loop. I got to the very end, step-17 in the guide.

The loop goes like this:

  1. The four colored dots circling around.
  2. Optimizing applications.
  3. Starting applications.
  4. And then it goes right back to the circling dots instead of starting up as expected.

I had upgraded the device to Android 5.1 and maybe this explains why my device is now stuck in a loop.

I have tried resetting the device and restoring it to factory defaults by powering it on holding both both the power button and the volume up button, but none of this fixes my issue. All it does is change the number of applications it wants to optimize when it's booting.

Any idears on how to get my device to boot properly?

1
  • May be the kernel has some issues. A similar issue once arose in my device when I flashed a new kernel in my device (not nexus). I had to revert back to my Nandroid backup. Since I'm certain you don't have such backup, your option would be to flash stock kernel (boot.img), do a factory reset and let us know the results.
    – Firelord
    Commented May 26, 2015 at 12:41

1 Answer 1

1

Using Firelords' suggestion I was able to unbrick my device and get it working again.

  1. Downloaded the Lollipop 5.1.1 image for Nexus 9 on this site: https://developers.google.com/android/nexus/images
  2. Unpacked all the files into the folder where I had fastboot.exe.
  3. Started my tablet by holding down the power button and the volue up botton to get into some kind of recovery mode.
  4. fastboot-all.bat did not work for me, so ran the following commands instead:

    fastboot.exe flash bootloader bootloader-flounder-3.44.1.0123.img
    fastboot.exe flash system system.img
    fastboot.exe flash recovery recovery.img
    fastboot.exe flash boot boot.img
    fastboot.exe flash cache cache.img
    fastboot.exe flash vendor vendor.img
    
  5. Reboot the device using the little menu on the screen. It was now able to start up, and I could recover from my latest backup.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .