In fact my WiFi DO HAVE Internet access, but for some reason it keeps telling me I don't and won't automatically reconnect to it. Now I have to manually reconnect every time.

So, is it possible to disable Internet access detection of WiFi networks?

I'm using CyanogenMod 12.1.

WiFi list Advanced WiFi settings

(click to enlarge image)

I've tried disabling captive portal detection, still no luck.

If your device is rooted, and have a firewall installed, you need to grant network access to Setup Wizard app (ID # 1000), so it can resolve the Google look up. I verified this in my situation by turning off and on my firewall, and checking the firewall logs.

I did not mess up with any editing of the captive portal settings. If you have the same problem, you have to forget the Wi-Fi networks in order for the SSID to be cleared. Once you grant network access to the Setup Wizard app in your firewall, the admiration point will disappear.

  • What do you mean by "the Google look up"? – RockPaperLizard Jun 27 '16 at 9:20
  • @RockPaperLizard To detect if there is an internet connection, the phone performs a cURL to a Google server. If it gets a reply, there's an internet connection. If not, it'll show an exclamation next to the wifi icon, or disconnect you completely. – eoinzy Aug 2 '16 at 10:54

If you open the menu in the wifi network list, you should be able to select 'Advanced' for the advanced wifi settings. Then try disabling the checkbox 'Avoid poor connections'. Even if Android thinks your wifi is too slow/not good enough, it should still connect and work like it should.

Keep in mind that disabling the checkbox will cause your device to try maintaining a connection to your router, even if the reception is very weak or the throughput is very low, which can affect your battery life.

Select "Advanced" in the menu Disable "Avoid poor connections"

(click to enlarge image)

  • Hi. I checked my phone and found that the checkbox is already disabled. So I guess it didn't help? But I'm not quite sure. I'll test again once I get back to my WiFi. – Inglis Baderson May 27 '15 at 12:26
  • Could you post what kind of device you are using? I took another look and it seems some Samsung are doing the exact same thing: android.stackexchange.com/questions/66964/… Could you perhaps add a screenshot of what you can see in the wifi network list when it disconnects, and what options you have in the advanced wifi settings? – gertmenkel May 27 '15 at 12:40
  • I'm using Galaxy S4(i9500) with and unofficial build of CM12.1. I think my problem is not the same as the question you posted because I can still connect to the WiFi, only I have to do it manually. I have the exact same options as in your screenshot in my Advanced menu. When it disconnects, it says something like "No Internet access detected, will not try to reconnect' under the SSID in the network list. Have to wait till tomorrow morning to get the screenshots though. – Inglis Baderson May 27 '15 at 15:07

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.