My Nexus 4 fails to mount with mtp mode. All other modes work (ptp, adb, fastboot). Three months ago I was able to copy the /storage/emulated/0 directory from the Nexus 4 to my pc for backup so all worked then. I was running the same systems then as now, Ubuntu 13.04 and Cyanogenmod CM11 M12. I have rebuilt the phone with no success. I have tried two other PC's running Ubuntu 13.04 with no success. There is no change in the response to "mount" before and after connecting the phone. The phone correctly shows "Connected as a media device". The response to "lsusb" correctly shows the phone connected:

jim@Toshiba-Satellite-M35X:~$ lsusb  
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub  
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub  
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub  
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub  
Bus 004 Device 002: ID 046d:c00c Logitech, Inc. Optical Wheel Mouse  
Bus 001 Device 005: ID 18d1:4ee1 Google Inc.    

Using "mtp-detect" I get the following response:

jim@Toshiba-Satellite-M35X:~$ mtp-detect    
Unable to open ~/.mtpz-data for reading, MTPZ disabled.libmtp version: 1.1.6

Listing raw device(s)  
Device 0 (VID=18d1 and PID=4ee1) is a Google Inc (for LG Electronics/Samsung) Nexus 4/10 (MTP).  
   Found 1 device(s):  
   Google Inc (for LG Electronics/Samsung): Nexus 4/10 (MTP) (18d1:4ee1) @ bus 1, dev 3  
Attempting to connect device(s)  
Android device detected, assigning default bug flags  
USB low-level info:  
   Interface has a kernel driver attached.  
   bcdUSB: 512  
   bDeviceClass: 0  
   bDeviceSubClass: 0  
   bDeviceProtocol: 0  
   idVendor: 18d1  
   idProduct: 4ee1  
   IN endpoint maxpacket: 512 bytes  
   OUT endpoint maxpacket: 512 bytes  
   Raw device info:  
      Bus location: 1  
      Device number: 3  
      Device entry info:  
         Vendor: Google Inc (for LG Electronics/Samsung)  
         Vendor id: 0x18d1  
         Product: Nexus 4/10 (MTP)  
         Vendor id: 0x4ee1  
         Device flags: 0x08008106  
Configuration 0, interface 0, altsetting 0:  
   Interface description contains the string "MTP"  
   Device recognized as MTP, no further probing.  
Device info:  
   Manufacturer: LGE  
   Model: Nexus 4  
   Device version: 1.0  
   Serial number: 00364595560f4a2f  
   Vendor extension ID: 0x00000006  
   Vendor extension description: microsoft.com: 1.0; android.com: 1.0;  
   Detected object size: 64 bits  
        microsoft.com: 1.0  
        android.com: 1.0  
Supported operations:


Does anyone have ideas on what to do next?

  • Do you strictly want this MTP for some purpose, or would an alternative would suffice as well? This site has answers for the alternative in case you need them.
    – Firelord
    May 28 '15 at 16:42
  • @Firelord I don't have to use MTP although it was very easy when it worked. It would be nice to figure out why it dosn't work now. Would you point me toward some alternatives that I can evaluate.
    – Jim
    May 29 '15 at 2:35
  • It would be good if MTP works out, otherwise you may consider the alternatives mentioned in this question.
    – Firelord
    May 29 '15 at 12:11

It seems you're on linux. If you're on debian or a derivative of it, try sudo apt-get install mtpfs. If you are on some other distro, try installing the mtpfs or libmtp package. Then reconnect your phone and it should work. This worked for my Moto E2 and G2 on Ubuntu 14.04

  • OP is running Ubuntu 13.04 and Ubuntu is a derivative of Debian, and is a GNU/Linux. That said, OP did say that MTP was working fine three months ago, which means MTP packages are already installed. OP also mentioned mtp-detect. Are you saying mtpfs or libmtp is different from those installed packages?
    – Firelord
    Jul 5 '15 at 18:07
  • I'm not sure if they are same or different, but my stock nexus 4 worked without installing the packages. I got an E2 and G2 recently, and they weren't working out of the box. I installed mtpfs and they've been working since then, and nexus 4 too
    – Chipset
    Jul 5 '15 at 18:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.