2

UPDATE

I have found this xda post with the partition table and sizes of the moto g. http://forum.xda-developers.com/showpost.php?p=48855450&postcount=35

I also found this xda post where they partition the emmc http://forum.xda-developers.com/showthread.php?t=2596521 , if someone could help me identify what should I put in adb.

My first gen moto g is stuck in a bootloop, everything i have done so far has not worked.I have tried to flash using fastboot and mfastboot with diferent stock images in all I get failed to erase partition, remote failure.

The internal storage says it has 0 mb of space. I have Twrp installed and using cat /proc/partitions finds no partitions

~ # ←[6ncat /proc/partitions cat /proc/partitions major minor #blocks name

I have managed to push a Stock rom but can´t flash it with mount data error,mount sd card error, mount system error and mount cache error..

I have tried to use Adb remount but it fails

remount failed: Success

Any help will be greatly appreciated

2

Assuming you selected correct partition info file (I didnt verify that from first link you posted, so thats up to you), I will only tell you what you asked-> What to really do in terminal from that tutorial.

Part one of tutorial is settings up ADB and getting things ready. You can also follow this tutorial to get adb ready. Then its about backing up things and getting ready (follow tutorial for all steps).

Part two is where main terminal process begins and all you have to really enter in terminal is those commands inside "boxes" (or code area). Just be open minded and read the outputs and interpret them carefully.

If you are trying to repartition and assuming partitions are corrupt because of this->

I have managed to push a Stock rom but can´t flash it with mount data error,mount sd card error, mount system error and mount cache error..

Then dont. Because your method of mounting partitions from adb is kinda... (incomplete?). Try entering these commands first and then flashing (whatever method you are using from adb)->

adb shell
su
mount -o rw,remount -t yaffs2 /system
mount -o rw,remount -t yaffs2 /data
mount -o rw,remount -t yaffs2 /cache

This should mount your partitions and you should be able to proceed with flashing. Even if you want to flash through twrp, you can go to Mounts option and make sure system, data, sdcard, cache etc is mounted by check marking them. Though I still cant understand how you are trying to flash a stock rom through sdcard/adb (I never owned a moto so idk what methods are used for flashing process).... but anyway, I told you method to mount those partitions. You need root to use those commands. See if they work. Because a mount error does not mean partitions are corrupt in any way. And make sure that adb can access your phone as root.

  • I think my partitions are corrupt or gone because using the command cat /proc/partitions it finds no partitions, in all the examples I seen they have a list of different mmcblk0 blocks.I tried to follow the code that you gave me but all my folders are empty in Twrp, I have folders but nothing in them adb shell ~ # ←[6nsu su /sbin/sh: su: not found ~ # ←[6nmount -o rw,remount -t yaffs2 /system mount -o rw,remount -t yaffs2 /system mount: can't find /system in /proc/mounts ~ # ←[6nmount -o rw,remount -t yaffs2 /data mount -o rw,remount -t yaffs2 /data mount: can't find /data in /proc/mounts – davidirhs May 28 '15 at 11:27
  • Ok, lets confirm that partition missing/corrupt theory. You use twrp right? In recovery mode, go to advanced, then Terminal Command, then enter the command df and that should list you the partitions. If this command gives pesky output then we can confirm your partitions being corrupt and you shall follow your method then. In any case, please do tell me output if you can. Thanks for feedback. – Jaskaranbir Singh May 28 '15 at 11:42
  • It gives me a table Filesystem 1K BLocks Used Available %Use tmpfs/dev 443852 48 443804 0 tmpfs/tmp 443852 24 443828 0 I don´t know if it is wrong thanks for all the help. – davidirhs May 28 '15 at 12:22
  • If the output was similar to this-> s24.postimg.org/hm587meb9/screen.png then its ok. Though sizes and number of partitions may vary, but partitions still exist then. – Jaskaranbir Singh May 28 '15 at 12:33
  • I don´t know if they are similar, mine don´t have data cache or system.I have uploaded a recovery.log in pastebin.ca/3012018.Cheking that I think that I have the partitions but they don´t know their own size. Partition Logs: /data | | Size: 0MB Used: 0MB Free: 0MB Backup Size: 0MB. – davidirhs May 28 '15 at 12:47

protected by Community Mar 24 '16 at 15:51

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.