2

I wanted to sideload Android 5.1.1 (currently running 5.1) to my Nexus 5.
I've sideloaded before and it's really easy, but now I've ran into a weird problem I can't seem to fix. The Nexus 5 is completely stock.

I connected my phone with the USB cable it came with onto my desktop computer (Windows 8.1) with the USB driver (08/28/2014,11.0.0000.00000) installed and USB debugging is turned on.
adb devices showed me a device, adb reboot recovery worked, but then Windows didn't want to find any USB device attached.
No sound, no nothing. It did not appear in the Device Manager (also not under the "Other devices" section)

Tried my laptop (running also Windows 8.1 with the same driver), but didn't want to recognise the device either. So, exact same problem.

After hours of searching the internet, I came across several potential solutions which I've tried but not succeeded with.
Koush's universal USB driver installer & Universal Naked Driver both did not work for me.

Then I tried following the steps in this article, which tells you to change the INF file of the driver. I've added various lines of code and installed it after disabling the driver signature check in Windows, but did not succeed.
The article tells you to add this line:

%CompositeAdbInterface%     = USB_Install, USB\VID_18D1&PID_D001

But that did not work for me. After reading this in the article:

The ID I saw in device manager against the Nexus was 
USB\VID_18D1&PID_D001, which didn't turn a lot up in Google!

I found my ID in the Device Manager when the device was booted into Android, changed the last part of the line, but that did not work in the end either.

I've tried using another cable as well, though I don't think that's the issue. It's plugged in quite firm and the device is being recognised in Android and the bootloader immediately.

Who can help me out?

Edit: I just got the update through OTA, but I still would like to know why my computers act like the N5 isn't plugged at all when in Recovery mode.

  • This may not be a solution or answer, but since my reputation isnt enough to make a comment... In case you are using twrp, try going to Mounts and enabling/disabling MTP (enable if its disabled and disable if its enabled). Then try connecting again? This has worked a fair number of times for me. – Jaskaranbir Singh May 28 '15 at 13:01
  • I'm not using twrp but tried it anyway. Did not work for me, unfortunately. Thanks for thinking with me, though. – Tom May 28 '15 at 13:29
  • You might already have tried that as well (but not mentioned): Does it work using a different USB port? Especially pay attention to USB2 vs. USB3. I've heard of several cases where the USB3 port caused problems. Concerning the .inf file: you can cross-check VID (vendor ID) and PID (product ID) using lsusb when the device is connected to your Linux machine. Be aware the very same device might present different PIDs depending on boot mode (recovery/bootloader/normal). – Izzy May 28 '15 at 14:46
  • I did try other USB ports. I even tried another machine. I tried it on USB2 ports on both machines. I noticed the change in different boot modes. It was different in normal and bootloader, couldn't check the recovery mode. I'm going to see if I can use lsusb on a linux machine. Thanks so far. – Tom May 28 '15 at 14:50
  • Hmm, I tried using lsusb and it showed the id and pid like it should in normal and bootloader mode, but once I go into the recovery, the machine acts like there is no USB input at all – Tom May 28 '15 at 15:10
1

it sounds like you don't have the correct drivers installed. there is a third-party windows based toolkit that runs a setup wizard available online. makes the driver install very easy. you can download it here.

  • However the driver installation was really well explained, it didn't work either. The phone just isn't plugged in either one of the USB ports if we have to believe Windows or Linux, but it is. – Tom May 28 '15 at 18:03
0

Okay, this is no daily task. I forgot two steps...

  1. When in recovery mode, press the power button and volume up.
    A new screen will popup.

  2. Select "Apply update from ADB"


Sorry peeps. Hope this will help some people though.. Maybe...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.