1

When my phone rings my screen is black - to unlock I have to press the button on the lefthand side which then ends the call.It used to automatically show the caller id but since an update I am unable to answer any calls :(. Hope some-one is able to help me please. Thank you

0

First go to Settings -> Apps -> Disabled(Tab). If you can find Dialer or Phone please enable it and then check after restarting your phone.

If your Phone/Dialer app is not disabled then try these steps,

  1. Settings -> Apps -> All(Tab) -> Dialer
  2. Clear Cache and Clear Data
  3. Disable it and restart phone and Re-enable the Dialer app.

If problem persists you can for emergency purpose attend calls using your motorola headset.

  • Thanks for your adivce - have done all you have said. Just have to hope this works. – Diane Viall May 28 '15 at 20:45
  • 1
    Thank you for your help. My phone is now working properly. I appreciated your help. – Diane Viall May 29 '15 at 10:56
  • @DianeViall Welcome. If my solution solved your problem you can accept it(check the tick mark) or you can post your own answer of what has solved your problem. So that its helpful for other readers. – Lucky May 29 '15 at 10:58
0

Honestly, without proper logcat pointing to exact bug is difficult. But it could be a rom bug most likely.

Anyway, you can go to Settings->Acessbility and there somewhere in calls options should be an option Power button ends calls disable it and your power button will no longer cut calls on power button press.

  • Thanks - but didn't work – Diane Viall May 28 '15 at 20:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.