0

I upgraded to CM 12.1 and lost root on my Samsung Galaxy S3 (I9300). I tried to root the device with CF-auto-root again. It worked. But when I rebooted the phone, the blue android screen appears and didn't stop loading resp. didn't continue. After rebooting again, the same happend.

Furthermore Clockworkmod Recovery has been replaced by Android Recovery, so I tried to reinstall it, but the installation failed.

I'm not able to enter Recovery mode (HOME+POWER+VOL.UP), instead "Downloading... Do not turn off target !!" appears. I can enter Download mode (HOME+POWER+VOL.DOWN). Finally, as already mentioned, the system doesn't start either.

What could I try?

1

Do not fret. Its a simple condition called bootloop.

First things first, root is merely nothing but bootloader unlocked. Rest stuff is just permission managers that interact with root.

So when you installed cm 12.1, you didnt actually loose root, you lost permission manager without which apps cant interact with root (in other simple words). All you had to do was install supersu or any other permission manager again from play store. CF-Root and stuff wasn't needed. Just telling for future reference....

Now for real problem. You can fix it using Odin (the samsung flash tool). First, download Odin. Then download framework corresponding to your region from here

Install samsung drivers.

Next run odin on your pc and connect your phone while its in download mode (First go into download mode and then conenct it. You actually went into download mode. That "Downloading... Do not turn off target !!" screen is called download mode, so you know how to go into download mode).

Make sure Odin recognizes you phone, it should say something like "com..." in one of the boxes which would mean odin has detected your phone. If it doesnt, your drivers arent proper.

Next extract the firmware you downloaded earlier using winrar. Then in Odin,

a) Click the PDA button and choose the file with .tar.md5 extension.

b) Click the phone button and choose the file with modem in its name (skip this step if file not found).

c) Click the CSC button and select the file with CSC in its name.

d) Click the PIT button and select the .pit file (skip this step if file not found).

Make sure that the "Auto Reboot" and "F.Reset Time" check boxes are selected in Odin. At the same time, uncheck/disable the "Re-Partition" option. Click it only if a .pit file is being used.

Then click "start" button and wait a while. It may take sometime. After process is done odin should show "success" and then you can restart phone (may take sometime at first boot. Wait atleast upto 20mins by watch). You will be back to stock android rom. Your phone is still rooted, only it doesn't have any permission manager or custom recovery.

First install something as permission manager (like supersu) from play store and set it up. Next, to install custom recovery, you can use twrp manager or similar.

After custom recovery is installed, you should be able to proceed with custom rom installations and such. Hope this helps :)

  • I was about to fret. Big thanks! Regarding the firmware download depending on the region, there are no European countries listed, so I choose Unknown (BVO)? Futhermore, I didn't use Odin, because it caused problems relating to a corrupt PIT file (I assumed it to be a bug) and I used JOdin3 before, because I'm a linux user. I changed to heimdall and everything worked fine. I could assume that root wasn't lost, but I did falsely, because I read it somewhere else in the internet.. Thanks for clearifying this! – de-facto May 28 '15 at 17:36
  • No problem. For region, probably try getting nearest or you can also try the unknown as you said. I actually didnt have a samsung to know how its region specific firmwares work, but mostly the only difference is the languages and baseband/modem (collectively called CSC). And worst case scenario should be you not getting any mobile network signal (which isnt a matter as you only need to get phone to start, then install custom recovery and flash some custom rom like cm and it will be all fine again). Again, I never personally tested... – Jaskaranbir Singh May 28 '15 at 17:46
  • Due to the lame internet connection it will take some time to download the firmware (it's size is 1.1G which is freaky). Maybe I'll finish it tomorrow and I'll post asap again as I did something! :) And interestingly, there is no 'nearest country' on the list, they are all so far away... ;) – de-facto May 28 '15 at 17:57
  • It's its of course in previous post. Ok, I have everything here now. I don't have a file for CSC. I have to use a PIT file. I can't select F.Reset Time (it's disabled). I click start, but nothing happens, I only have an increase in CPU usage for 20 seconds, nothing more. But I will give it 20 minutes as you said. No progress in Odin and no progress on phone visible so far. (Phone is connected indeed says Odin)^^. Gn8 – de-facto May 28 '15 at 20:17
  • Well that's a problem... In any case, if it doesn't work then you can also try odin 1.7 (yeah, sometimes older version works. Happened to my friend). If even that doesn't work, its probably drivers (just Odin detecting phone is not enough sometimes, try uninstalling any existing drivers as well as any other phone's drivers from device manager and install raw Samsung drivers). You also have an option to try heimdall in case Odin doesn't work. – Jaskaranbir Singh May 28 '15 at 20:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.