0

I have a Nexus 6 that doesn't boot after a failed Android M developer preview install (worked perfectly on my Nexus 5).

Booting into fastboot via power + volume down shows the device is unlocked but says "connect USB data cable". I believe "connect USB data cable" is the critical problem preventing any kind of recovery.

It is connected via the cable that I used to reboot it into fastboot successfully (and I've tried unplugging and re-plugging it in) so I think the cable is not the problem.

I'm guessing it's permanently bricked?

  • Have you tried using the Nexus Root Toolkit (yes, purists hate toolkits, but they're very handy in situations like this) and its functionality for reflashing stock Android even when it's bootlooped? It's very, very unlikely that the M preview could have killed your USB port. Also, the drivers may have changed. You'll want to check those, too. But NRT can help with that. – TurboFool May 28 '15 at 22:40
  • 2
    I did give that a go and it failed, but I did magically get it working (I think, phone is rebooting now, knock on wood) by rebooting my computer! Something was weird about the USB connection or maybe ADB/fastboot. Was able to reset to factory using this: androidrootz.com/2014/11/nexus-6-one-click-mac-toolkit.html – Tim Trueman May 28 '15 at 22:54
1

So the solution for me was to reboot my computer. Whatever the ADB/fastboot connection issue was went away after that. I definitely tried adb kill-server + adb start-server, tried switching USB cables and ports, etc. …rebooting was still the only thing that fixed it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.