1

Here is my situation:

I have frequently used tethering to pair devices with phone phone and it has worked spectacularly. At one point I moved 50gb of data over my cell while I sought out a dedicated service provider.

The only caveat was that it would give me the t-mobile hotspot splash page if I hit a non-ssl page from a laptop. After some investigation to verify I discovered that this was based on the user-agent (force the user agent to identify as a cell phone browser and it works fine but you get the mobile page).

The issue: Since the upgrade to 5.1, when tethering, my mobile devices (any) show the '!' on the wifi connection to my tether.

*results of the investigation

  • I verified I was indeed getting the t-mobile splash page
  • Same issue when tethering with my Nexus 5 and Nexus 4 (both 5.1)
  • No problem on my wife's nexus 4 with my SIM (5.0)
  • No problem when using wife's sim/phone (5.0)
  • No problem using my sim in my friends nexus 4 (5.1)
  • Doesn't work with his SIM in my nexus 5.
  • Any device that pairs to my cell (even if it's another nexus 4/5) get's the tmobile splash. Leading me to believe it's not entirely user-agent based.

  • I have heard that 5.1 is much more aggressive at trying to figure out legitimate wifi connections and I wonder if this has something to do with it?

Anyone have a clue what the blocking logic is and if the tip-off is android based, phone based or sim based? What changed between 5.0 and 5.1 that might effect this?

Update

As suggested, I turned off captive portal detection. The '!' went away but I still get the t-mobile splash screen when I use HTTP. When I use HTTPS I just get a connection timeout.

So, there is still a user agent detection going on with http.

Theory:

  • My tablet sends it's user agent as a tablet and that isn't permitted on my tmo plan, so it's block. Ok, so then I had a friend of mine use his cell to tether to my phone. He still gets the splash.

At this point I have to actually see what's going over the wire to t-mo. How can I intercept that? Easy way with adb?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.