0

So, here is my problem: One time, I am setting an alarm, but I noticed that my phone doesn't have a stocked Clock app. I also go to /system/app/ClockPackage_ESS.apk using ES File Explorer. I installed that .apk, but when I'm trying to install it, it says "File not installed."

Here is the screenshot (click to enlarge) of the App Drawer:

App Drawer

Also, here's the device information:

Device Information: Samsung Galaxy Core Prime Model number: SM-G360HU Android version: 4.4.4 (Kitkat) Baseband version: G360HUXXU0ANL6 Kernel version: 3.10.17-388893 dpi@SWDD6214 #2 Thu Feb 5 16:44:31 KST 2015 Build number: KTU84P.G360HUXXU0AOB1

Does someone know how to fix this problem?

0

Your phone does have clock if there's that app inside system/app as you told. Its not necessary that it must be shown on launcher, though normally clock apps are shown. I suggest you give a try to some third party launcher on store and see if that does some trick. On contrary, you should be able to access clock by tapping the clock in notification panel.

Also, if there's some app inside system/app, its already installed. And apps inside this folder are called system apps. You cant install them like normal apps by simply tapping and pressing on install (or rather they dont need to be installed like normal). You install them by simply pushing their apk file to system/app or system/priv-app depending on type of app and then setting their permission to 755 or rw-r-r with some file manager. So that "install failed" is justified. In other words, app is already installed.

  • Thanks, @JaskaranbirS. I have installed CM Launcher from Google Play Store, and still the Clock app was not there. I also searched "Clock" on the Local Apps/Web, and it has no results. Also, as you said, if I tap Clock on the Notification Panel, it just go to the Date & Time Settings. – Lloyd Dominic May 29 '15 at 4:48
  • Then its the way clock app is made mate. You can either install third party clock app from store or use it from notification panel. There are ways that might force it to show on launcher by decompiling it and editing manifest. But its kinda not worth the trouble. Anyway, if my answer solved your query then you should mark it as solved for future reference :) – Jaskaranbir Singh May 29 '15 at 4:51
  • What's the correct permission to set? You've mentioned two different permissions, 755 and rw- r-- r--. 755 is equivalent to rwx r-x r-x, whereas rw- r-- r-- is equivalent to 644. Click here to learn more about Android permissions. – Lloyd Dominic Apr 19 '18 at 2:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.