0

My timezone is GMT +5:30 but it always changes it to GMT +2:00. Please help me fix this problem. This made me miss an important meeting.

0
2

I'd first check your settings under Date & Time (at the bottom of the settings menu).

Possibility 1: Automatic time zone is deselected.

  • Issue: Your phone is manually setting an incorrect time zone.
  • Solution: Select Automatic time zone

Possibility 2: Automatic time zone is selected.

  • Issue: Your phone is automatically selecting an incorrect timezone
  • Solution: Set your time zone manually by deselecting Automatic date & time and pressing Select time zone below and setting it to Kolkata or Colombo (both GMT +5:30).

Let us know if either of these fixes your issue!

Not the answer you're looking for? Browse other questions tagged or ask your own question.