I'm having an issue on my Nexus 4 (Stock Android 5.1.1).

It keeps disconnecting from my Wifi. When I go back to connect, it says "No Internet access, automatic connection impossible".

I currently live in China so my guess is that Android checks if internet is available by querying a Google server, which is blocked in China so it then concludes "No Google = No Internet" and disconnects me from my Wifi.

I can't find any way to disable that Auto-Disconnect "Feature".

  • 1
    Can you check in your WiFi settings about an option "Avoid poor connections"? Make sure its disabled. – Jaskaranbir Singh May 29 '15 at 19:16
  • 1
    Nope, there is no such settings. (Advanced wifi settings screenshot on my phone) – refreshfr May 29 '15 at 19:20
  • Why have you got a VPN running? Disable the vpn and try again. – Thomas Vos May 29 '15 at 19:53
  • Disconnections happen when the VPN is not running (because when it is running, google server are reachable). I had the VPN running on the screenshot in order to be able to upload it. The Wifi settings menu does not change if a VPN is running or not. :/ – refreshfr May 29 '15 at 19:56

I know this is an old thread, but I found the solution. Enable airplane mode, then enable wifi. It will show the internet connection is down, but wifi will still work. Then you can disable airplane mode and it will stay connected to the wifi (until you leave the coverage area, then you'll probably need to do it again when you return).

  • 1
    Thanks for your reply ! I no longer live in China and I no longer have the issue I described in my post. So unfortunately, I have no way of testing if your solution works ! Let's hope it'll work for other people having the same issue as I did :) – refreshfr May 10 '16 at 13:04
  • This just turns off mobile data, which obviously will make the connection fall back to Wifi. Wifi was never actually disconnected. – Nimrod Apr 21 at 21:26

My experience is that Android verifies the connection to a google server.

Guess what's blocked here (China). Right. Google.

Apparently Android's new policy is to prevent auto-connecting to trusted networks if it can't see any internet on the network. Which of course there is, may it be slower and limited to the Chinese Firewall.

So far I haven't found a way in Android to disable this check. And I'm forced to use 3rd party apps to solve this issue.

If I ever find a proper fix, I'll definitely post it here.

Failing to auto-connect

Screenshot - Failed to auto-connect (Click to enlarge image)

I travel here frequently, so I need this.

  • I'm assuming the Chinese ROMs use a different verification server? – Huey Jun 23 '15 at 8:42
  • No doubt, Fastest servers they can check here are probably from Baidu. – Ariaan Jun 23 '15 at 8:45
  • [Tin-foil-hat-mode] Or probably an other government server, that keeps track of your location. – Ariaan Jun 23 '15 at 8:48
  • Or nothing at all (old style Android) – Ariaan Jun 23 '15 at 8:49
  • This is interesting. It should really check several servers in case one is down or blocked. – Huey Jun 23 '15 at 8:59

Check your Wifi encrytption. WEP dont seems to work , get it changed to WPA/WPA2

  • Do you mean WPA rather than WEP? – Dan Hulme Jul 15 '17 at 12:20
  • Yes, my bad. I edited the response – Mehak Jul 24 '17 at 9:57

protected by Community Jul 15 '17 at 12:19

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.